Roon Arc doesn't work outside the local network

Roon Core Machine

Mac mini (M1, 2020)
MacOS 12.3

Networking Gear & Setup Details

Huawei B525s-23a
4G internet
Local network on ethernet
no VPN

  1. Who is your internet service provider?

Play (Poland)
4G internet

  1. Please list the make and model of your modem and router?

Huawei B525s-23a

  1. Do you have any additional network hardware, like additional routers or managed switches?

Silent Angel Bonn N8 Ethernet Switch

  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?

no VPN
no proxy servers
no firewall
static IP on Roon Core

Connected Audio Devices

Audio source chain:
Roon core (Mac Mini M1 with static IP) ––> Silent Angel Bonn N8 Ethernet Switch ––> StackAudio Link II Network Bridge ––> Mytek Manhattan II DAC (USB)

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Diagnostic Data for Roon Support:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“188.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

Roon Arc works fine in local network but it doesn’t work from outside via internet.
I have tried many different settings on my router but have not been successful. The Roon Core and Roon Arc upgrades also didn’t solve the problem.
What am I doing wrong and what should I do to enjoy my private music cloud?

Best regards,
Marcin

@Marcin_Bortnowski, welcome to the community and sorry to hear about your issues getting ARC to work. Is your Internet service using fixed wireless or a mobile router from Play? Have you tried to create a port forwarding rule on your Huawei router that matches to the port number in your Core’s Settings → Roon ARC tab, or is there an option to enable UPnP on the Huawei router?

Hello,

Thank you for your answer. My Internet service is fixed wirless. All connections from my router to audio equipment are wired. Port forwarding is created. UPnP is enabled. I send you all importatn settings of my router and Roon core computer in screenshots.




Marcin, thank you for these photos, they are helpful. A few observations:

  1. It still appears that you have two routers in your network based on the error message. I understand fixed wireless networks (my company designs these for other mobile carriers) and you bandwidth speeds are very good, but also want to confirm that you don’t have any other networking devices other than the switch in your network.

  2. I see that you have both port forwarding and UPnP enabled. Best to select one or the other and try to see if ARC connects. If you use port forwarding (which appears to be configured properly), does this port number match exactly what is listed in Roon’s Settings → Roon ARC tab? Roon sometimes moves this port number (mine can vary between 55000 and 55002), so my port forwarding rule covers ports 55000-55002.

Hi Robert,

  1. In my home network I also have wifi extender (TP-Link N300). However, I tried to disconnect it, but nothing has changed.

  2. I have tried different router configurations – enabled only UPnP or only port forwarding or both and so on. The result is always the same. In port forwarding settings port is the same what is in Roon srttings. I have tried 55000, 55002 and few others. According to what I read on various forums, this problem may be with my ISP blocking incoming traffic (my IP is not a public IP). I don’t know if it is really possible?

Best,
Marcin

Hey @Marcin_Bortnowski,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

After reading through this thread, @Robert_F has provided excellent steps toward getting Arc up and running. I’d be curious to hear what your ISP says in regards to CG - Nat. Below are a few questions you can pass their way to paint a clearer picture:

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

I’ll be monitoring this thread for your reply :+1: