Roon ARC forgets port

Hi,
My Roon server is behind two routers.Configuration:
internet <> router 1 <> Router 2 <> Roon server
I opened port on router 1, to router 2 manually.
In Roon → settings -. Roon AR C I fill in an Roon opens on the second router and redirects it to the Roon server, Everything works okay ARC on my portable works okay.
But sometimes Roon server forget the port. It field in etting → Roon ARC is empty and of course “it” don’t work. Remedie is simple: fill in port and ARC works again.
So not really a problem but annoying, because when I forget to check the port at home. ARC does not work when I’m “outside”.
Am I doing something wrong? I should expect a “savce” button, but I can not find it.
Kind regards Edwin

I moved your post from #uncategorized to #support so that more people see it. And capitalized ARC in the title for visibility.

Hey @Edwin_Slee,

Could you please update to the newest Core and Arc build and let me know if you continue to experience this issue?

I’ll be on standby for your reply :+1:

Hi Benjamin,
New version, new phenomenon :slight_smile:
settings → about:
Roon version 2.0 (build 1182)
You have the latest version installed.
settings - Roon ARC:
Not ready

port is already in use
Roon core is running on Windows 11

netstat -ab
indicates that the port is connect the process RoonAppliance.exe
Which is correct, but why the settings → roon ARC error message :the port is already in use
by an other process?
BTW I did a clean reboot of the system.
KR. Edwin

Hey @Edwin_Slee,

Thanks for the update! Have you run a port checker just to double-check that the current port number you’re using isn’t secretly being used by something else? A free site to test this on could be : https://portchecker.co

Beyond this, have you tried using a different port number altogether? Here is more info on this :

Hi,
I’ve “killed/aborted/stopped” the roon server and restarted it again. Then from my PC I started roon client, fill in the port and everything worked okay, ( settings → roon ARC : status Ready.
Then I rebooted the OS and started roon-server.
On my pc I started Roon client: settings → Roon ARC port was empty!
Fill in port : then status became ready.
I started the ARC app of my mobile and t worked as expected.
Then I again “killed/aborted/stopped” Roon server and started it again.
On my pc I started Roon client: settings → Roon ARC port was empty!
Fill in port : then status became ready.
I started the ARC app of my mobile and t worked as expected.
So after restarting Roon server the port is still EMPTY
The new build of Roon server did not solved the “discomfort”.
KR, Edwin

Hey @Edwin_Slee,

I appreciate the step-by-step, but I’m wondering if you tried any of my above suggestions? Did you run a port checker on the specific port number you’re using with Arc? Try using it both when it’s connected with Arc, and after Arc seems to drop the connection.

With that, have you tried using different port numbers? Please let me know :+1:

I would also pull up your router port forwarding settings to ensure it’s properly saving your rule.

Hi Ben,

I have run the port test. That only means that I have set up the port-forwarding correctly on the first router. if there is no listener on the server behind the second router (that should be Roon server) the test will also give an okay result.
I tried THREE different ports after I’ve stopped/started Roon server.
According to settings → Roon ARC the connection is okay.
BTW, I also opened the ports on router 1
However, when I stop and start the Roon server, the port field is empty again. In all three cases.
KR.Edwin

Hey @Edwin_Slee,

I didn’t see any mention of your specific router model and ISP, are you able to provide that information? It seems as though your router is forgetting the port forwarding rule that has been created.

We haven’t been able to find anything around enabling ARC diagnostics on your account. Please take note of the date and time the next time this happens and share it here :+1:

ISP: KPN Metherlands
Router 1 KPN Expedia 10v (ZTE H369A)
Router 2 ASUS RT-AX86U

1 Like