Roon Arc - initial setup issues with router

No worries :slight_smile:

Whether you need a static IP for Orbi and your Core:
If possible, avoid it, but it does not mess up anything if you are careful and set up the correct static IPs for each device and correctly reference them in the rules. Whether you can avoid it depends on the capabilities of the AT&T and the Orbi - I don’t know them:

What’s important is that the rules always point to the IPs of the Orbi and the Core. Depending on the routers, this may be achieved in different ways:

  • Good routers let you use automatic IP assignment by DHCP, while still having the option of using a specific IP for each device. This is preferable to static IPs because there is less chance of messing it up, as the router ensures that each IP is only used once. If this is possible, there should be a setting for the device. E.g., on my Fritzbox it looks like this - I don’t know if something similar exists on yours:
  • When setting up port forwarding rules, good routers may also make such a fixed assignment by DHCP unnecessary, because they may automatically always assign the correct IP to a device that is used in a port forwarding rule. Again, not sure how yours do it.
  • Good routers will do away with the mess of IP addresses completely, by assigning names to IP addresses in the network. Like in my above screenshot, I assigned “fireTV” to this device and the router’s DHCP assigned an IP to it. I can always reach the device by its name, regardless of what the IP is. I suppose this is not an option for you because otherwise your rule should show the device name already. (Most devices announce a basic name on the network by default, if this is possible. E.g., a Roon ROCK appears as ROCK automatically)
  • If nońe of this is an option on your AT&T/Orbi, you will have to set up static IPs. Just ensure that each IP is used only once on the network, and that you are clear on which device is which. Pen and paper help to avoid a mess :slight_smile:

Did you go to Roon - Settings - Roon ARC and verify for sure the IP address of your core and the port number?

This seems fine now in the latest incarnation of the rules on the Orbi:

It may depend on the device. Some are combined modem/routers and then they have an option for forwarding rules. Some are just a modem and then they don’t, but in this case they also don’t need one as they are not concerned with routing (where the port forwarding comes in) and only have modem tasks (modulating/demodulating the low-level electrical signal on the cable).

But yes, check the manual of this AT&T thing what it says. If there are no such options, the single port forwarding rule on the Orbi is probably all you need - and if it still doesn’t work, although the Orbi rule is now fine, the problem will be elsewhere. For instance, in the latest error message I am seeing that autoconfiguring ports via NATPMP and UPnP seem both active - I am not sure about that, but seems odd.

Also, please copy the error text from the Roon app (select all, then Ctrl-C) and paste it here. In the screenshot, the end is cut off

Okay, here’s where we stand now. I found instructions on the ATT modem and was able to set up port forwarding. It appears the only way to do that is through a NAT/Gaming screen. I now have the following set up on my ATT modem:

I set up the Global Port and Host Port fields to all read 50000. Let me know if you think something different needs to be there.

I then ran the Roon ARC test. Error message is now as follows:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}



There was one last step on the ATT NAT/Gaming page that I needed to complete. After defining the custom “Roon” service, I still needed to add that newly-defined service on the main page.

ATT modem screen now looks like this:

Roon ARC Settings now looks like this:

Hopefully my trials and tribulations will be useful to someone else stumbling across this thread someday. Which reminds me of the following:

Thank you @Suedkiez, @Robert_F and @Maarten_Duits (and others) for all of your help along the way! Now I’ll be able to listen to my favorite music on my trip tomorrow!


Fabulous, well done! Enjoy!


Thank you to our very helpful Community members who supported on the thread here (@Suedkiez, @Maarten_Duits, @Robert_F).

@RICK_JOHNSON, please let us know if you have any continued connectivity issues with ARC, and the tech support team has flagged this ticket for a prompt troubleshooting response.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.