Roon ARC just spins after tapping core

Roon Core Machine

Mac Mini 2012 running Debian 12

Beta channel of Roon core.

Networking Gear & Setup Details

Ubiquiti Dream Machine SE and APs, switches etc. 1G Fios link.

Connected Audio Devices

5 Roon endpoints.

Number of Tracks in Library

15,000 local and as many from Qobuz

Description of Issue

Roon ARC just spins. After finding my core and tapping to connect.

Using latest TestFlight version. Have also tried the standard App Store, same issue.

Hi @Tristan_Harward ,

Thanks for your message. Has ARC ever worked for your Mac Mini before or is this a new install? Sometimes Linux firewalls can interfere with ARC being set up properly, have you tried to temporarily host the Roon Core/Server on a different PC and check if the issue is the same?

If you are using the production version on your Roon Core, then it is suggested that you use production on the phone as well. What is the model/manufacturer of the device you have ARC installed on?

Hi - thanks for the reply.

Yes, it had worked since ARC’s launch with the same core and same phone.

I first deleted the Test Flight version completely, and re-installed the production app. Was still experiencing the same spin.

I finally just waited and let it spin. I think being on the same WiFi as the core helped speed along the process, but it finally loaded up and began working again.

It took at least 5 minutes.

It’s a large library so potentially just had a lot to download.

Anyway, problem solved. ARC is working normally now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.