Roon Arc no longer working - cannot connect to core

Hi there,

I have a Roon Nucleus as my Core connected via a Swisscom router. Since launch Roon Arc worked perfectly until this summer. Since then it has not been able to connect to the core. I spoke with Swisscom and they informed me that there had been no changes on the network, and the router is the same.

It will only work in the house if I am connected over the WiFi but of course, in house I use the core directly.

Any colour / help would be greatly received.

“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“176.hhh.iii.jjj”,“actual_external_ipv6”:“2a02:aaa:bbb:ccc:ddd:eee:fff:ggg”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nAction Failed\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

@JM77, from reading online it appears Swisscom uses CGNAT in their network. CGNAT allows a service provider to share their limited number of public IPv4 addresses across their subscriber base.

Unfortunately Roon ARC does not work on networks using CGNAT. There are two possible options. The first is to see if Swisscom can assign your network address a static IP address, although there may be a cost to do so. The second option is to use Tailscale’s VPN service for using ARC outside your home.

Hi Robert - many thanks for the colour. Much appreciated. Do you know if Roon are working on a solution for CGNAT networks?

I believe they are continuing to look at different approaches. Some of the Early Access builds of Roon were updated to address some of these issues, but I do not believe they are fixed completely yet.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.