Roon ARC no longer working, not launching beyond splash screen

Roon Server Machine

Roon rock intel NUC8i3BEH

Networking Gear & Setup Details

WiFi/Mobile Cell

Connected Audio Devices

Google Pixel 8 Pro

Number of Tracks in Library

Approx 20k

Description of Issue

Roon Arc app on pixel 8 only opens to splash screen and nothing else. Tried to uninstall and reinstall but same issue. Does not matter if it is on WiFi or mobile.

Anyone help?

Had the same problem today. Rebooting ROCK machine helped.

Tried rebooting and still didnt work. The same thing happened with the last update a month ago and the roon team provided me with a link to an apk install instead of the playstore. But I don’t want to be doing this every time there is an update to the app.

Try removing the app from your phone and reinstalling.

Worked for me.

Thanks for the suggestion. I have tried this several times but still no luck.

Hi @Billy_k,

There’s a fix for the bug you’ve been encountering over in the Early Access section - you’d need to switch your RoonServer instance and ARC over to the Early Access branch to test by following these instructions.

If you don’t want to move to the Early Access (beta) branch, then you can wait until the fix merges to the public build in an upcoming release. You can use the APK in the meantime.