Roon ARC not configuring

Roon Core Machine

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

My first post… My question might not be well categorised…

I get the following error message when I try to get ARC to connect with my Roon Core:


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}


I suspect an ISP or router issue. I am getting no help from my ISP and do not know what settings to change in my router. Any ideas out there?

Hi @Marc_Brillon,

Welcome to the forum. To help you with your problem it is for me and other community members usefull if you answer all the questions in your original post. If you answered the questions we look at the problem and hope to find a way to solve it.

Kind regards,


Please note:

1 - My ISP is b2b2c (based in Quebec, Canada)
2 - The ISP supplied a combo modem/router by Smart RG. Model number SR516ac
3 - There are no additional routers / managed swithces
4 - The network does not have VPN’s, proxy servers or high-end security


Have you tried setting up port forwarding on your router? Looks very similar to an issue I had with ARC. I manually added port forwarding to the router with the ip details and port shown on the ARC settings page in roon.

1 Like

I also set up a static IP for my roon core while I was there. Not sure this was required but seemed like the safe option.

Hi @Marc_Brillon,

As mentioned by @Andrew_Munro, you should try to create a manual port forwarding.

First in the Roon App under Settings → Roon ARc write down the IP address and port number shown there.

Take a look at the manual on page 69 and see if you can create the port forwarding.

In the first screen click on Add
Under Interface i think you can select your Roon Core (it’s the IP address you wrote down) select that one.
Then select Custom service and enter a name ie. Roon Arc
in Trigger Port Start and End enter the port number you wrote down.
As Portocol Roon Arc only needs TCP. Try that one first. If ti’s not working, you could select *TCP/UDP

Click Apply and Save.

Check in the Roon App under settings → Roon Arc if it’s working.

Hopel it helps.


1 Like

Hello Maarten (and thank you Andrew).

Using the steps you proposed, I was able to get connected.

In case this is of potential use to others facing similar connection issues, the router had to be set to
a specific interface standard. My router proposes Eth4.1, PPP0.1 and PPP1.1. Only this last WAN Interface standard (PPP1.1) worked for connection with my Roon Core. Also, I had to use the TCP/UDP protocol.

Bottom line, the connection was activated and I am now a (happy) user of Roon Arc. Thank you for your help, much appreciated!



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.