Roon ARC Not connecting

Roon Core Machine

Mac OS Monterey

Networking Gear & Setup Details

Bt Home Hub

Connected Audio Devices

Number of Tracks in Library


Description of Issue

I get this error message when trying to connect to ARC: {
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I have the same issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Running netgear router, netgear mesh extenders and netgear access points with a couple of switches. Roon core on QNAP TS-H686 (I have deleted IP above, let me know if this is required)

Same to me
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
} 7530 AX + Deco-x50

Setting up port forwarding has fixed this for me. Was surprisingly easy to do. Check out the troubleshooting for information.

Is Port forwarding the same as Port Mapping?

Not sure. I have a Port forwarding / port mapping setting in the router. I added it to port forwarding. All the details you need (IP and PORT) are in the roon arc settings screen.

The Roon ARC page in settings says “Not ready”.

I’m getting this error:

{“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I have manually Port forward, by entering the static IP of the core and using port 55000 for both the private and public LAN/WAN which is the same as the Core IP.

I don’t understand this error message and therefore don’t know how to correct the problem

The ROCK is connected directly to the router with Ethernet cable.

I have put xxx in the external address for safety as this is a public forum.

Is port 55000 what was requested in the ARC app?

It was not for me. It was a different number. I used the one on the ARC settings page. Saw someone talking about this on another thread. Seems to work if I use the port on the app.

Whoever I replied to has deleted the post, but yeah you have to match the port requested in the app to the port you forward to the host device. That’s how port forwarding works!

Troubleshooting may be helpful for experienced users. I love music and port forwarding (with a mesh router by tp-link is a mystery for me.In the deco app I took the port, the arc app suggested, still no connection

Hi you need to look on your Roon, settings, Roon ARC all yore info for port forwarding can be found here

My understanding is that it doesn’t matter what the number is as long as it is the same in Roon Core and in Port Forwarding. 55000 is the “usual” number used .
I don’t see anywhere in the ARC app where the port number can be found.

…it doesn’t matter as long as the port-number is not already used by another service :wink:

Roon recommend to use 55000

Sorry if it did not help for you. It may be a different thing causing an issue for you. I was just commenting that the port forwarding had sorted my issue as I hoped it may help others.

It is difficult to give instructions on how to update port forwarding on your router as it will vary from model to model. I had to look for it in the settings of mine although it was quite straightforward once I found it. I just added the exact numbers shown on the Roon app (detailed elsewhere in the replies). Hope you get it sorted soon.

Thanks, but I’ve got no issues with connecting on my setup. I was replying to someone else offering assistance although the post I was replying to seems to have disappeared.

Hey James.

I had this same issue.

I had enabled port forwarding and Upnp on my router but still no dice. I narrowed it down to my ISP blocking all port forwarding at their end.

Go here and check if there are any open ports, or just try the ARC one 55000 or whatever you’ve set up.

If it fails then it may be the same issue I had.

I called them up this morning and they unblocked port forwarding for me, and after a modem reboot I was all good to go.

BTW; I’m in Australia with aussiebroadband , took me a 2 min support call and no charge. Good luck.

If Roon ARC is not connecting, it’s probably because the automatic port forwarding did not work on your router. It works on some, not on others. So, you’re going to need to do this manually. If you have more than one router, such as router behind a router, it get more complicated.

You need to know your Roon core device IP address and the port number it’s using. In Roon, go to Roon - Settings - Roon ARC. You will probably need to click the down arrow where you should see the IP address ( for instance) and the port number (55000 or 55002, etc.) Those are the numbers you will need to create your port forwarding in your internet router.

From here, every router is going to be different. I found what I needed by googling “port forwarding for my router make and model.” You will also need the IP address of your router to get into the router setup and you will need the password to save any edits you make to the settings. If you don’t know those, see if there is a label on your router with that information.

Once, in your router settings, identify your Roon core device by IP address or name, as I found (Nucleus), and follow the instructions to create the “pinhole” or port forwarding. Then save and exit. I’m not sure, but you may need to reboot your router to have the port forwarding take effect and you may need to reboot your Roon core, and restart your Roon program on your control device.

That’s about all I know, but post a thread of your own in the Support category and someone should come along who can help you. By now, just about every make and model router has probably been encountered.

I am obviously no expert at this, but this is basically what I did with my AT&T U-Verse Pace router, and it worked.

Thanks for recommending calling the ISP to see if they can open the port. As you, I’ve tried EVERYTHING I know to do with no results.

1 Like

Hi Mate , Im with Optus . My Roon Arc is not working either , I tried all sorts of config on my unifi udm pro, still nothing works . I just did the Port Checker and it came out as " Port Closed" . Should I call Optus and ask them to open up that port ?. Cheers. Emmany