Roon ARC - Not ready. Port forwarding issue?

Roon Server Machine

Intel NUC

Networking Gear & Setup Details

Living in Norway with Altibox as provider.

Modem: ZYXEL VMG8825
in bridge mode

Router: USG Pro 4
UPnP - disabled
Firewall rule:
From Any
Port 12840
Forward ip 192.168.30.14
Forward port 12840
Protocol TCP

Does your network have any VPNs, proxy servers, or enterprise-grade security?
No

Connected Audio Devices

All streaming works inside network, including ARC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Roon ARC
192.168.30.14
12840

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“81.aaa.bbb.iii”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Roon ARC have worked before, but might have been some changes in settings over time that have caused this problems. Not sure where to look next for solving this issue.

Router is restarted, modem is taken off bridge mode and back in. UPhP / Nat is tried on but gave other errors.

You need to enable either UPnP/NAT-PMP or set up manual port forwarding rules. This is a prerequisite for everything else. In the error above (“upnp_autoconfig”: {“status”:“NotFound”}) it seems that at this time you had neither.

If there was a different error with UPnP enabled, then it’s well possible that UPnP as such worked, but it then revealed another error. So it would be interesting to see this error.

Port forwarding rule is as described in first post.
Same values as in the Roon setup.

Do I need more than 1 rule?

Sorry, I missed that. Looks essentially fine but why are you using port 12480? Is this the port that is shown in Roon > Settings > Roon ARC? Seems low for an automatic Roon port, did you specifically change it? Though any port in the private port range (49152 - 65535) should be fine, as long as it’s not used by anything else. It’s possible that ISPs block certain ranges, so you could try some other values.

Hi @Terje_Andersen,

From our understanding (based on this announcement), Altibox has joined Telenor, Telia and other Norwegian providers in their implementation of CG-NAT (carrier-grade network address translation).

This is effectively a blocker for either UPnP or manual port forwarding at the level of your internet provider. One alternative is to rely on IPv6, if you have dual-stack available at your internet account level.

A simpler and increasingly popular option is to rely on Tailscale, a proxy-mesh VPN service that can traverse CG-NAT successfully if installed on the RoonServer machine and ARC phone.

You can start here:

Please let us know if this helps. Thanks!

2 Likes

Have tried several ports, but with no luck. so guess it is not the port that is the issue.

Thank you. Have spoken to Altiboks and they deactivated cg-nat on my subscription. Works now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.