Roon ARC "Not Ready" with docker internal subnet address detected as IP

Roon Core Machine

Linux 5.10.120+truenas
(Docker instance in TrueNAS)

Networking Gear & Setup Details

Amplifi Router HD v3.7.1
Ethernet

Connected Audio Devices

RoPieee, ROCK as bridge, Elac Discovery Z3, etc

Number of Tracks in Library

45000 tracks

Description of Issue

Settings > Roon ARC says “Not ready”

{
"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"73.202.240.XXX","router_external_ip":null},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}
}

The Roon IP that it detects for this is apparently on the Docker/K3S internal routing subnet, and thus does not have access to the router for uPNP (which should be supported). The “ROON CORE IP” in this settings pane is from the internal subnet 172.17.0.x, while access to Roon locally is through 172.16.1.x. The Roon “General” and “About” settings correctly identify Roon’s 172.16.1.x address.

The Roon ARC app correctly connects to Roon on my local network, but warns (consistent with the above) that it will not be accessible outside my home.

I’d say that the legacy IP detection code works better than what’s exposed by the Roon ARC tab.

This looks super-promising, looking forward to using it fully sometime soon!