Roon Arc not working on my network (UMDPro Router + ISP Modem)

Roon Core Machine

Mac Montery
Antipodes K40

I’m sorry of the below is wrong, but what would I need to do to enable Arc on my UDMPro Router.

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

1 Like

Hi John,

Do you know if your ISP is giving you a CGNAT IP? You might have to call them to find out, if they are, I think you can request them opt out and get a direct IP instead.

1 Like


Thanks for the quick reply.

I have a static IP address, is this the same as a direct IP?

I recommend you to not make your IP public in forums

1 Like

Have you tried enabling UPnP on your router and letting this create the port forwarding rule?

This would rule out any syntax errors in your manual rule and prove it can work.


1 Like

Tried that before and didn’t work.

My Cable Modem located upstream from my UDM PRO, but I don’t know how to access it

Dude don’t put MAC addresses and such on a public forum!

1 Like

All this IP Addresses and Mac addresses is new to me, so thanks for the warnings

In the first pic you have the port set to 60000. In the pic of the arc setup in roon it is 55002. Those two need to agree. I would set the router to 55002 to match roons setting.

That was me just mixed the order of the photos after me trying different port settings - they’re both the same in Roon and my UDM Pro each time and I’ve tied multiple different combinations but still no luck with Arc :frowning:

My ISP provider has got back to me and confirmed that I am not on CGNAT

“I can confirm we do not use CGNAT for our connections. They are provisioned as a full routed IP address.”

I realise Roon must be super busy after the 2.0 roll out, but would appreciate if someone from support could please reply to the issues I’m having not being able to set-up Roon Arc.

13 days and not one single reply from Roon Support, what a disappointment :-1:

Hi @Celts88,

There’s no excuse for having endured such a long wait time, so please accept my apologies on behalf of the team.

The status code present in the original diagnostics you sent (998) suggests that there’s an issue with your local network preventing Roon from accessing our servers, independent of ARC. This is likely a firewall or security issue, although there are several possibilities. First off, for due diligence, I’d verify the following:

  • Is your router firmware up to date?
  • Do you have any VPNs, proxy servers, or enterprise-grade security on this network?
  • Are you experiencing any issues with Roon Remotes, or other apps on your local network?

Who is your internet service provider? Knowing that will equip us to help you access the modem web administration page to confirm the modem is in Bridge mode, and to verify there aren’t other network security settings upstream from your UDMPro router.

Most users with your router have solved their issue by placing the modem in Bridge mode - see this post: Arc - Port Forwarding (UniFi Dream Machine Pro)

We’ll be watching for your response.

Connor, thanks for getting back to me. I’ve been away for the last week so apologies for the late reply, see below for requested info

  • Is your router firmware up to date?
    UDM Pro, yes on latest firmware

  • Do you have any VPNs, proxy servers, or enterprise-grade security on this network?
    None of the above

  • Are you experiencing any issues with Roon Remotes, or other apps on your local network?
    No issues that I’ve noticed

  • Who is your internet service provider?
    Future Broadband. I’ve checked and not on CGNAT (provisioned as a full routed IP address).

My Cable Modem (Touchstone CM8200) is located upstream from my UDM PRO

Hi @Celts88,

We’ve dug a little deeper into diagnostics and discovered a slew of general network errors.

Your Roon Core is unable to reach ARC, but it’s also failing to connect to servers at Google, Dropbox, and the majority of Roon services involved with the everyday operation of Roon and Remotes. There appear to be IP address assignment issues in your local network underpinning these issues; however, the errors congregate on 10/23, and haven’t appeared since.

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP-provided server to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps? It may stabilize some of the assignment issues.

In addition, one or more of your network devices appears to be prioritizing IPv6 over IPv4 (the latter is the recommended address format for all things Roon at this time, still). I recommend disabling IPv6 in your router settings, on your Core network settings (if relevant), and on any endpoints.

Please let me know once you’ve had a chance to test this out, and we’ll be standing by to respond more promptly.

Sorry for the dumb question, but where do I change the DNS Servers?, and what is my current one?

I think I’ve deleted any reference to IPv6.

Think it’s working now

Add images

1 Like

Hi @Celts88,

I’m sorry I missed your previous question regarding DNS assignments. The DNS server would be assignable within the DNS section of the router’s web administration page. This admin page is usually accessed by entering the LAN IP address into a web browser.

If you’re not sure about your specific router, the manufacturer or internet service provider will generally have instructions for their particular brand.

However, it seems everything is working now. Have you been able to access ARC on a cellular connection? If so, then the automatic configuration was indeed successful.