Roon ARC not working with Eero/AT&T fiber

Roon Core Machine

NUC (one of the suggested models) running ROCK 2.0 (build 1311)

Networking Gear & Setup Details

  1. Who is your internet service provider?
    AT&T Fiber optic, BGW320-500 modem

  2. Please list the make and model of your modem and router?
    Eero Pro 6e

  3. Do you have any additional network hardware, like additional routers or managed switches?
    network switches

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    no

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
{
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“99.hhh.iii.jjj”,“actual_external_ipv6”:“2600:aaa:bbb:ccc:ddd:eee:fff:ggg”,“router_external_ip”:“192.168.1.65”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.4.1”,“found_upnp”:true}
}

I don’t use ARC often but I think this started after I switched to AT&T Fiberoptic (from Xfinity) about 6 weeks ago. Earlier in the summer, Roon Arc had been working perfectly fine. Please see attached screenshots from Eero app.

@Jason_Gould, are you using the BGW320 and eero both in routing mode, or is one in bridge mode and the other router in router mode? I have two routers in my network, one from AT&T and one from ASUS. To get ARC working with two routers, you need to do one of the following:

  1. Set the eero to bridge mode and let the BGW320 handle all routing and IP address assignment

  2. Have all network connections run through the eero, with the eero being the only device connected to the BGW320, and de-activate WiFi on the BGW320. The eero and BGW320 both remain in router mode (this is similar to what I have).

Then for Option 2, do the following:

A) Create a port forwarding rule on the BGW320 from the BGW320 to the eero using the LAN IP address of the primary eero router and the port number being what is shown in Roon’s Settings → Roon ARC tab.

B) Create a port forwarding rule on the eero router from the eero router to the computer running your Roon Core using the LAN IP address of the computer running Roon Core and the port number being what is shown in Roon’s Settings → Roon ARC tab.

Eero is in automatic mode and not bridge mode. Are you suggesting turning off both the HOME and GUEST SSID on this screenshot (from my AT&T modem)? I am tech-lite so I want to make sure I understand your instructions before I start making changes. I apologize but I will probably have some more questions as we move along. I appreciate the help.

Jason, I removed your image as it has your AT&T router’s password visible. Typically this wouldn’t be an issue but as this router is what is connected directly to the Internet, it poses a risk.

I do not know who the eero is configured and what options are available. How is WiFi served in your home? Do you have WiFi activated on both the eero and BGW320? In most cases this should be coming from one system or the other as the AT&T and eero routers don’t typically have a way to integrate their WiFi systems across the routers. Just my experience, maybe other eero users can provide additional guidance.

I turned off the wifi (2.4 and 5). I’m trying to figure out the port forwarding instructions you gave. Which of the tabs should I use in the firewall section below when configuring the port forwarding on the modem?

Also, do I use the IP address that I see on the modem (192.168.1.65) or the one I see on my eero app? See two screenshots.

I think I got it! I appreciate your help. Have a good weekend.


1 Like

NAT/Gaming is what you need for the '320. I have an older AT&T gateway with a much different interface. Glad you are ready for ARC now.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.