Roon ARC poor connection

ARC used to work fine. Now when I try to use it, I get the “poor connection” message.
I updated the software, restarted the phone, still get the message even if I’m on wifi , 6 ft from my router.

If you want to ask for help from Support, please post in the #support category and fill out the post template with the full details of your system and network setup. Thank you.

Go into ARC Settings on your phone, scroll to the bottom, and hit Reset Roon ARC. That has worked for me and other people.

4 Likes

I had the same issue as OP, thanks for the tip…

1 Like

That’s right, thank you!

1 Like

Andrew, that worked, thanks.

1 Like

This didnt work, I re-installed the roon arc app, it now has been trying to connect to my core for 20 mins. My Core has ethernet connection at 1GB/Sec speed and my iphone is on my office wifi with 100 MB/sec .

@Roman_Benvenuti - rather than posting in an old thread, if you want help on your issue, please open a new support request in the #support:port-forwarding-help and give full details of your Roon and networking (including your ISP) setup.

Also say whether your Core is reporting that ARC port forwarding has been successful (Settings > Roon ARC)