Roon ARC Suddenly No Longer Working

Roon Core Machine

Mac Studio Apple M1 Max 64 GB RAM

Networking Gear & Setup Details

WiFi Charter/Spectrum Router

Connected Audio Devices

Apogee Element 24

Description of Issue

Recently, I began having trouble connecting with Roon using Roon ARC in my car. This week, however, I cannot connect at all to the Roon Core from my car. Now, I cannot even connect when at home. Below are the diagnostic data:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“69.aaa.bbb.ccc”,“actual_external_ipv6”:“2603:7000:201:4c83:40b6:5c4f:8699:72b2”,“router_external_ip”:“69.aaa.bbb.ccc”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

The computer is new (this week), but settings, router, etc., have not changed. Please advise. Thank you.

@Kevin_Shelton, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

It also appears that you may have two routers in your network. If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thank you for your reply.

Before I take the steps you mention, I want to report some bizarre behavior by Roon ARC.

This morning, I checked the Roon Core settings, and I was still being told that I could not connect to my Roon Core, not even at home. Yet, when I tried to play a couple of different songs in different playlists, they played!

I kept ARC playing while I went to my car, and started driving. The sound continued for a while, then stopped, and I could not connect again. What could possibly be going on?

If you were playing ARC at home over WiFi, then the port forwarding issues, UPnP settings, etc. don’t matter; ARC plays similarly as to the Roon Remote application, but with more limited output and configuration settings. When you moved to your car and switched to a mobile network. the song(s) playing were cached locally on your phone from your WiFi connection, and when the cache was empty/done playing, ARC didn’t have any more music available to it locally, and it stopped.

OK, thank you for the explanation. I found it very odd when it did that!

I will try the steps you indicated now and let you know whether they work or whether I have questions/additional problems.

1 Like

Did you restore a Roon backup? Seems likely on a new computer if you run the Core on it. If yes, you may be experiencing two different issues.

After restoring a backup, ARC may show „can’t connect to core“ even on home wifi. This is a known issue, I reported it recently in earlyaccess and they have a ticket for it.

This does not, however, lead to an error message in the Roon ARC settings. So this may be a different or additional issue in your case.

Yes, it was restored from a system backup on an external drive a few days ago when I got my new computer. I was having some connectivity problems in the car before that, but now it is kaput.

I edited my post with additional info while you answered, see above. The issue with „can‘t connect to core“ on wifi will probably be fixed by uninstalling and reinstalling the ARC app. Then it should work again on wifi.

However, the port forwarding issue leading to the error message in the settings is most likely a separate one that needs fixing as well

Is the phone with ARC currently on the wifi? “Waiting for remote core” does not sound like it.

The uninstall/reinstall ARC only helps with the “can’t connect to core” issue after restoring a backup, and this issue affects access both on the local wifi and, even if the port forwarding works, also remotely. If this was part of your issue, after reinstalling it should work on the wifi in any case.

But it won’t fix the remote access because you have a separate problem there according to the diagnostic message in the Roon ARC settings

I relaunched the ARC and now it’s telling me that my Core isn’t configured for access outside my network. I am now completely confused.

OK, I have deleted and re-installed the Roon ARC app, enabled UPnP/NATPMP and re-done the port forwarding via my router. I used the My Spectrum app to do this.

Now, the app says, “waiting for remote Core” and is stuck there. There is still no connectivity between ARC and the Core.

I don’t see any information about “Bridge mode”.

Further information that was requested:

IP: Spectrum.

Location: Northeastern USA.

Modem/Router: D3.1 eMTA / Model E31U2VI

No additional hardware.

Did you enable UPnP and created a manual port forwarding rule? You should do one or the other - many routers don’t deal well with it when both are present

1 Like

I did do both; thanks for mentioning this (although I think that they were both set even when ARC was previously working). Roon is now accessible to Roon ARC.

HOWEVER, it appears that my Roon now has two different names. Roon ARC is trying to connect to KShelton1s-iMac, which no longer exists, so it is just spinning its wheels. How do I rename it to its new name on my new computer (KShelton1s-iMac-18), so that ARC can find the Core that is on this new computer? Or is that even the right solution?

1 Like

My Roon ARC works fine at home and using my phone remote from home. However, although the app on CarPlay is present it a) won’t display artwork, b) will only play from the iPhone i.e. there is no control through CarPlay but total control through my phone. Initially, it worked fine through CarPlay, bright ideas accepted! Rob

Uh weird, I never saw that happening. No idea :frowning: Reinstall ARC again maybe, after you made the port forwarding work again, if you haven’t done so yet. Maybe it then finds the new core

You should open a new topic of your own in Support as your issues are completely different from the ones here in this thread.

However, there are, I think, already existing threads about CarPlay not displaying artwork and possibly about control issues. For instance:
https://community.roonlabs.com/search?q=carplay%20art%20display%20order%3Alatest

I know; it’s boggling my mind. I deleted and re-installed the app, but it’s still only looking (in vain) for KShelton1s-iMac, which no longer exists for some reason. I have no idea how or why my Core got re-named, or what to do about it (I’ve checked the settings to see).This is really getting frustrating.

Maybe someone else has an idea. @Robert_F?

Many thanks for your help and advice so far, Suedkiez!

1 Like

@Kevin_Shelton, can you confirm you have only one Roon Core running? Has a Core been installed on any other computers that are active right now, or has a Roon Remote been turned into a Roon Core?

Can you post screenshots of:

  1. The view from your Roon Core’s Settings → Audio
  2. Your Roon Core’s Settings → Roon ARC
  3. From your Charter router, the list of connected devices?