Roon Arc Test error

Roon Core Machine

Synology DS918+
DSM 7.1

Networking Gear & Setup Details

R7000 + openwrt side router running on raspberry pi 4B

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I had set the port forwarding 55002 port → side router) , in side router, I set port forwarding 55002 port → (my roon core)

when I test Roon Arc, got the following error

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 153.ddd.ddd.eee:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“153.ddd.ddd.eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Are you sure that the ARC port is indeed open from internet? You can check it with this link . Fill in your ARC port number (probably 55002) and click the button “User Specified Custom Port Probe”.

I am using DDNS, domain name :, mapped IP is, I can access my NAS, router, raspberry pi SSH correctly. I used link you give, this site say my computer IP is, and I can’t specified IP, so I can’t test my domain’s port.

I had used another site to test it, it says the port is open

Thanks for the extra info.

I’ve read your posts a few times now. A few things came to mind: see below. Also, I don’t quite understand your setup. It looks like you have placed a router behind a router (and thus NAT behind NAT) where the function of second router is fulfilled by a Raspberry. Such a setup with two routers is sensitive to the kind of problem you describe (see posts about it on this forum).

Other things that comes to my mind when I read your posts (maybe they help you finding the problem and a solution or giving you new ideas):

  • I am not sure but I think that the two subnets you have behind each other are using the same IP-range ( Although this is possible from a theoretical point of view, it does not increase comprehensibility. My advice would be to use different IP ranges for the two subnets.

  • In your post I see different IP addresses for your internet connection. I see for example: 153.ddd.ddd.eee,, It could be that this is a problem for Roon ARC. Perhaps that during the Roon ARC test Roon Core is sending an message to the central Roon Server on one internet IP address while the confirmation is expected on another internet IP address. Or something like that.

  • Is it possible to do a test with the Raspberry temporarily removed from your setup (with the portforwarding from internet via the first router) directly to your NAS IP address? If this is working than you know the problem has something to do with the settings in the Raspberry.

  • Did you do a test with the NAS firewall and/or the Raspberry firewall disabled?

1 Like

Hey @Jason_Huang1,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, @Alfred_van_Hoorn has made some excellent points, and has absolutely asked the proper next questions. Did you end up getting Arc sorted out, or are you still running into issues?

I’ll be on standby for your reply :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.