Roon ARC Troubles with RT-AX92U Asus Routeur

Roon Server Machine

LAPTOP Lenovo Ideapad 330S Intel Core I5-8250U ; 1,6 GHz ; RAM : 8 Go

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Orange Box
  2. Please list the make and model of your modem and router?
    LiveBox + Routeur ASUS RT-AX92U
  3. Do you have any additional network hardware, like additional routers or managed switches?
    No
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No
    I have a WPA2-Personal Level Of Security (Login / Password) for the Routeur

Connected Audio Devices

The Routeur ASUS is connected to the livebox by cable
The LAPTOP is connected by WIFI to the Routeur
My Music is stored on my NAS. The NAS is connected to the Routeur by cable

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“92.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

I tried to have a static IP address for the Roon Server, to enable NAt and UPnP options, and to configure the Port forwarding, without success … Thanks in advance.

This is the setting I used for my Asus RT-AX88U

Obviously my Roon server is set to use 55000 and not 55002.

I also have uPnP disabled and I use dynamic IP for my Roon server but I have a DHCP reservation for it in the Router settings so that it is always assigned the same ip address.

Thanks for your reply. I Took the port number on the Roon Page
image
I disabled UPNP option. And for the DHCP reservation I have set like this

it seems i’m not so far from your settings …

Hi @Benoit_Alaurent,

Thank you for your post.

ConflictInMappingEntry This entry in your original diagnostic indicates that another software program has reserved the port that was autoassigned by Roon.

Try changing to another port entry, like 56000, in Roon ->Settings → ARC and any associated port forwarding rules.

Thanks for your help but the following message is still remaining.
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“92.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

I restarted Roon and my routeur and here is the message :
{
“external_ip”: {“actual_external_ip”:“null”,“actual_external_ipv6”:“null”,“router_external_ip”:“192.168.1.11”}
}

Bonjour @Benoit_Alaurent,

Dans le diagnostic le plus récent, il est indiqué qu’un problème NAT persiste en amont du routeur Asus. La Livebox peut avoir des paramètres dans l’interface graphique pour transférer le port - ceux-ci doivent correspondre à la règle que vous avez créée pour l’Asus.

Si vous rencontrez toujours des problèmes, il est probable que le groupe Orange lui-même bloque ARC avec son CG-NAT. Ceci est courant si vous êtes en France et utilisez Orange Group France.

Vous devrez alors demander. Demandez directement une adresse IP WAN dédiée à Orange ou optez pour une option VPN en #bricolage, comme TailScale