ROON ARC unable to access my Roon core

Roon Core Machine

2021 MacBook Pro, Apple M1 Pro Chip, Ventura OS, 32GB memory

Networking Gear & Setup Details

FRITZ!Box Fon WLAN 7390 Router in basement connected by LAN cat6 to Orbi Router RBR750 for wifi to house

Connected Audio Devices

Bluesound Vault 2i Lan

Number of Tracks in Library

8500 tracks

Description of Issue

Roon ARC not connecting. turned off VPN and firewall. no difference

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 14.aaa.bbb.ccc:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“14.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

How did you configure the port forwarding on the router? Did you create a manual port forwarding rule in addition to having UPnP enabled? In this case, don’t do that, some routers don’t deal well with this and it may be the cause for your error. Do one or the other and see how that goes.

Or allow the UPnP only for your Macbook, the Fritzbox may let you do that (mine does) instead of allowing UPnP generally. (And then don’t create a manual rule either, let UPnP do the work)

thanks for your suggestion. I appreciate your assistance. I didn’t create a manual port forwarding rule. The UPnP checkbox it checked. I tried unchecking but didn’t change the block. I looked for where I could UPnP only for the Macbook but couldn’t find. Welcome any further help

Please turn on the VPN and use VPN port forwarding feature if available. If that is available copy and paste the port number on the Roon app.

Could be an ISP issue with your external IP address. ISP networks often don’t provide real IPv4 addresses that can be port forwarded, but instead use something called CG-NAT (Carrier-Grade Network Address Translation).

In that case, enabling a VPN may work around it like @Saravanan_Kannan wrote

Alternatively, sometimes the ISP can accommodate you. Let me copy the usual response by Roon support for this issue:

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?