Roon ARC unable to access Roon Core 02

Roon Core Machine

MacBook Pro 14 2021, Apple M1Pro 16G

Mallin nimi: MacBook Pro
Mallin tunniste: MacBookPro18,3
Piiri: Apple M1 Pro
Ydinten kokonaismäärä: 8 (6 suorituskyky ja 2 tehokkuus)
Muisti: 16 Gt
Järjestelmän laiteohjelmistoversio: 7459.141.1
OS Loader -versio: 7459.141.1
Sarjanumero (järjestelmä): KF49PQLPW5
Laitteisto-UUID: D0212789-23C7-5B70-BF6B-22CC521E68E8
Provisiointi-UDID: 00006000-001464103A62801E
Aktivointilukituksen tila: Käytössä

Networking Gear & Setup Details

Huawei N5368X Ethernet

  1. Who is your internet service provider?

Elisa oyj (Finland)

  1. Please list the make and model of your modem and router?

  2. Do you have any additional network hardware, like additional routers or managed switches?

  3. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

That is a 5G router, I believe, so you are using a mobile network provider as your ISP (Elisa oyj).

It is highly likely that your mobile network provider is using Carrier-grade NAT. You can see that if you can compare your public IP with your WAN IP (on the info page of your router). If both don’t match, your ISP uses CGNAT and it’s why you won’t be able to use ARC as long as you don’t have a dedicated public IP.

Your ISP (Elisa oyj) will need to give you a public IP address (either static or dynamic) for ARC to work. Can you check with them whether they can do this?

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


Thanks for the answer. Some days ago I finally managed to get the ARC working, but it was not an easy task. An expert from my internet service provider (Elisa, Finland) worked some 30 minutes (=77 euros!) to make the connection work. The guidelines on Roon’s webpage are such technical jargon that I could not understand them. Your guidelines above are not much clearer for a non-professional person.

As far as I understand, Roon’s idea is the opposite: to make listening music easy and intuitive, so that the computers almost disappear. To my experience, this is how Roon usually works.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.