Roon ARC - unable to connect to core using 4G

Roon Core Machine

Mac mini (M2/8GB)

Networking Gear & Setup Details

Provider: iiNet (Australia) connected to NBN Fibre over node
TP-Link VX420-G2v

Connected Audio Devices

Synology NAS for music storage
Devialet Phantom speakers for playback

Number of Tracks in Library

8755 tracks

Description of Issue

I have never been able to use ARC to connect to my core outside of the house, ie., using a 4G connection. It works okay when I am on the home wireless network.

I’m not sure if it is important to mention, but I am also running a Plex media server on this computer.

I’ve been putting off creating a ticket for this, hoping that it would be fixed with an update. Any help would be greatly appreciated.

Best wishes,
Sean

I get the following diagnostics message:

{

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“203.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“0.0.0.0”},

“status”: “status”: MultipleNatFound

,

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}

}

Do you have a router/modem from your ISP and a second router?

See here:

1 Like

Thanks for taking the time to reply with such a comprehensive response. I don’t think my ISP uses CG-NAT, as I looked at my IP address on the modem settings and looked up my IP address in a browser and they matched. There’s no other hardware involved in the setup - just a Mac mini connected to the modem/router, with the NAS also connected to the modem/router. I’ll take a look at the other links you provided. Greatly appreciated!

I’ve just tried adding bridge mode to my settings and this seems to have worked. Thanks again.

1 Like

Everything seems to be working okay. I Googled how to set my modem/router to bridge mode and that fixed things.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.