Roon ARC unable to securely access core at home!

Roon Core Machine

Sonictransport wired connection

Roon ARC is reporting that it is unable to securely access the Roon Core. I have tried all your troubleshooting steps.

Networking Gear & Setup Details

Google

  1. Who is your internet service provider?
    Xfinity
  2. Please list the make and model of your modem and router?
    Google
  3. Do you have any additional network hardware, like additional routers or managed switches?
    Google
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No.

Here is the diagnostics data:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“98.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.86.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

The diagnostic message suggests UPnP isn’t configured correctly. However, I note that you have Google devices in addition to your ISP modem.

It is likely you have a redundant layer of networking, i.e., two subnets. Therefore make sure core and controllers are connected to the same router, and forward port 55000 from the ISP router to the Google router and from the Google router to your core.

@Martin_Webster Many thanks for this. Alas, I am not sure I know how to do what you want me to. I am not that tech savvy, I am afraid. I did go to the Google wifi router’s settings page, found the Core and set the external and internal ports to 55000, to no avail.

@Martin_Webster I got it figured out, and RoonArc is now ready. Thanks for this.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.