Roon ARC unable to securely access core

Roon Core Machine

Salkstream III (running Linux Arch)

Networking Gear & Setup Details

Netgear N300 WNR2000v2 router, Netgear Prosafe GS105 unmanaged ethernet switch; everything connected via ethernet cable

Connected Audio Devices

Anthem AVM20 pre/pro via optical, Oppo 103 via HDMI. Remotes include iPad 7th gen, iPhone 12 Pro, Windows 10 PC (almost never use the Windows 10 PC).

Number of Tracks in Library

22395 (local + Qobuz)

Description of Issue

Getting this error when trying to set up Roon ARC

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”(edited out)",“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I checked the router and upnp is on. I tried toggling it off and on, but that didn’t help. I followed the instructions to manually set up Port Forwarding in the Port Forwarding router settings, but I still get the same error message.

Note, I’m a novice at this level of router setup, so much of what I saw in the router settings was foreign to me.

I see lots of posts with similar issues, but not many solutions. :frowning:


Manual port forwarding… jeez… are we in the 1990s? What was roon thinking?

Never mind, I figured it out.

In the core settings for Roon ARC, the Port number at the bottom didn’t match the router settings. I could have sworn I entered the same number, but when I double checked it, it was different. I set it to the same Port number and it appeared to connect fine with no error message. Accessing the core outside my network now appears to working now (I just played a few seconds of a track on my iPhone 12 (wifi turned off so it used cellular network) to verify and it played fine.

Btw, the instructions for manual setup included this

“ Static IP - if you’re going to manually configure port forwarding, you’ll want to ensure your Core is always using the same IP address. This can be done by setting a static IP address on your Core or otherwise configuring your network to ensure your Core always uses the same IP ”

I could not figure out how to do this, so I guess if my core IP address changes, it will no longer work?

I don’t see how an average user can deal with Roon without IT knowledge. Even the answers to support questions often contain IT lingo and references to checking all kinds of computer/network/router settings that the average user has no clue about. Personally, I struggle with and hate working through issues like this. Sadly though, it seems the nature of the beast with “computer audio” no matter what software one uses. It sure is great though when it’s working well (fortunately most of the time in my case).

There are times I’m tempted to go back to spinning CDs. :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.