ROON Arc with no connection!

Roon Core Machine

Apple Macbook Pro 14” 2021
Apple M1 Pro

Networking Gear & Setup Details

Fritz!Box 7590
Fritz!Repeater 2400

Ethernet connection

Connected Audio Devices

Devialet Expert 250 Pro
ROON Ready Wi-Fi

Number of Tracks in Library

87,742 tracks

Description of Issue

This same thing keeps coming back to me.
Losing the ROON Arc connection with my ROON Core. It really pisses me off quite a bit… I’m no wizzkid but I only wish to listen to my music on-the-go. :blush:

Help please ROON.

Hi @Sjors_Ehv,

On the tab Roon ARC in Settings in your Roon Remote you’ll find a diagnostic message. Can you copy that here?

1 Like

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<?xml version=\"1.0\"?>\n<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n403\nNot available Action\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>”}

Hoi Joost_Hoogland, this is it.

Has something happened?
I think at last, it’s working now

Exactly the same thing for me works for a while then stops. I don’t have local files just use Roon as a transport and UI so I can use tidal but this thing is a PITA it’s so temperamental

I haven’t successfully connected mac-mini core to netgear nighthawk which uses DHCP auto internet connection.UPnP is activated.However, I receive the same ‘error 504’ message. What is the the problem?

Hi @Sjors_Ehv,
It could have something to do with your internet provider.
1.What is your provider and you have a modem/router from your provider additional to the Fritz!Box?

1 Like

I’ve been suffering from random “port closed” errors for a few weeks now. My modem has port forwarding enabled and everything works fine until one day, for no apparent reason, it stops working.

My solution is to change the port number and configure everything again. I now have 2 port forwarding settings on my modem so I can switch ports, restart the core and get everything working again.

Hoi Joost_Hoogland,
I’m having Dutch KPN Provider, with Fritz!Box 7590 as main and also one Fritz!Repeater 2400 added as an extra.
Is this too much maybe, for my room? Or what would you suggest ? :slightly_smiling_face:
Kind regards, Sjors

Hi @Sjors_Ehv

Is your core plugged in to your main Fritz router of the repeater?

Is the main Fritz box your ISPs or is there another box?

Edit: your ISP might be in the list of ISPs with an issue

1 Like

Hi Menzies,
Yes it is plugged in my main Fritz!Box.
Sorry the other thing I will have to have a look…

Kind regards, Sjors

I don’t know Menzies. What is an ISPs I don’t really know :slightly_smiling_face:

The ISP is your internet provider. They appear in the list of providers in that link.

1 Like

Hi @Sjors_Ehv,

I have the same Fritz!box with KPN. I have set up port forwarding and disabled uPnP in the Fritz!Box. That works.

1 Like

Hi Joost_Hoogland,

Thanks. I have tried to set up port forwarding, but I see there is still 0 active.

With kind regards,Sjors

Did you enter the port number you find on the Roon Arc tab in Roon’s Settings? I do not see it in the screenshot above. I’m not at home so I can’t check it in mine.

No I think I did not.

Do you mean in this window?
If yes, what should I choose ?

Thanks again :upside_down_face:

You should enter the port number that is displayed on the Roon ARC tab in Settings of your Roon Core. Fill that number in the last three fields (that mention port) in the above screen. For protocol choose TCP or TCP/UDP.

Joost_Hoogland yes, I’ve done that.