Roon Arc with Qobuz does not work

Roon Core Machine

Synology DS918+ 12GB

Networking Gear & Setup Details

ASUS RT AX88U

Connected Audio Devices

iPhone 13 Pro

Number of Tracks in Library

5.000 tracks

Description of Issue

I have a very specific problem that Qobuz does not work with arc when away from home. Local media and Tidal work just fine. As soon as a track is to be streamed from Qobuz it never works and shows poor connection. The home network is 300/50 and the mobile network is around 150/50 just tested. As soon as I join the local Wi-Fi Qobuz streaming via arc also works fine. My phone is a IPhone 13 Pro is that is of interest. The only special setup I can think of is that I have the ISPs router and than connected to that my personal router as I don’t trust the ISPs device and want my network isolated.

Please help me as it really ruins the arc experience. I don’t want to keep tidal I only tested it and go with Qobuz

I think that you need to check the purpose of ARC, it is only available to use your local files and not your streamed music as far as I am aware. This would explain the behavior that you are experiencing.

You can stream qobuz and tidal in ARC, just not download them.
The qobuz stream comes straight from qobuz to your end device so not sure why Tidal would work, which does the same thing. Though they use different protocols.

Does it play via the qobuz app ok? Might be the provider has a bad CDN connection to Qobuz or your trying to stream hires without adequate bandwidth, Tidal is only 48/24 max for streams to the device where Qobuz will be higher dependant on content.

2 Likes

Ah, thank you for the clarification.

both tidal and qobuz work fine through the dedicated app. It is only Qobuz that does not work through arc

i just tried with my wifes Samsung phone and there Qobuz can be streamed just fine. So it seems to be specific to IPhones? Maybe even IPhone 13 Pro

A little more experimenting shows actually similar problems with Tidal. Also shows poor connection some of the time if streamed with arc.

I tried the native Tidal and the Qobuz app with highest quality and it worked perfectly. Both played tracks in highest quality without issues…

Roon Arc on the other hand does not manage to start streaming tracks in bandwidth optimized mode most of the time. My network should easily be sufficient. I just did a Speedtest which showed 100Mbps/s download.

Use iPhone 13 ARC and all service works fine so even Quboz

Use Mac mini M1
50K tracks

At first I did not realize that Qobuz streaming does not go though the core. So I am now really puzzled what is happening here. Is there Any way to get a log file or something to see what is really happening when poor connection is shown?

In continued trying different things. It seems I need a few tries going airplane mode and back until a Qobuz stream works. The interesting thing is that as soon as one track plays the next ones work fine as well. I listened for an hour today without problems after the first track worked. Does anyone know a way how I can check arc logs. The Roon core does not seem to show anything.

Hey @Michael_Klug,

Following up on this thread, can you please reproduce the issue and grab a specific timestamp (date, time) to share here?

After enabling diagnostics on your account, we’re seeing many low memory pressure errors when you’re running Arc. What do your storage settings look like on your iPhone? How big is the library you’re storing on Arc?

I’ll be on standby for your reply :+1:

hi @benjamin!

Roon arc has nothing downloaded und states in iPhone settings it is using 900mb storage.
I guess the memory pressure problems occur when arc is crashing after reopening if arc has not been used for hours or days. This is not a problem for me as I only land in the Startup screen after one second.
The poor connection problem itself has just disappeared after a few days. I have just reinstalled arc to be sure and it did not happen again. It seems the Qobuz implementation is or was a little bit sensitive as I saw more threads with Qobuz poor connection problems.