Roon ARC wont connect to core

I have configured port forwarding and enabled UPNP on my Asus rt-ax86u. I have followed the steps here: https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Manual_Configuration

Roon still shows this message when trying to enable ARC:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xxx.xx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Why on earth does it not work?

Which ISP are you on in which country

…and are you using the Asus rt-ax86u with the ISPs router / modem?

Sweden, Bredband2 and fiber connection.

I have no router/modem associated with my ISP. I am connecting the rt-ax86u directly to my fiber converter. I use Asuswrt-Merlin though, but that should make no difference.

I have tried that and it seems that my ISP is using cgnat. However, I really don’t understand why Roon choose to use UPNP which is considered an unreliable and unsecure protocoll for remote access.

I would see myself as pretty good with network configurations, but this ARC thing is way to “difficult” to put together for any common user. Why make it this difficult when Roon could just set up a privat tunnel (VPN) or something for every user. Somehow they must have been able to make this much easier. You should only need to enter your credentials and then the app should connect with no hassle.

you don’t have to use upnp, you can set it up manually

ARC doesn’t support ISPs that use CGNAT, i.e., where the IPV4 address is shared by multiple service users. If you reach out to your ISP, they may provide you with an IPV4 address (possibly for a fee.)

I found a solution for my needs. Maybe it can work for you too.

https://community.roonlabs.com/t/tailscale-implementation-with-arc-to-circumnavigate-isp-cgnat/215356