Roon ARC Won't Connect

I have never been able to access my Roon core from any location except at home on my wifi network. Even with 3 bars on 5g Roon Arc gives me the “poor connection … unable to reach core server” message when wifi is turned off or if I am not on my home network, no mayter how much bandwidth. I have reinstalled RoonArc and get same results. I am running on an iPhone 15 Pro and ios 17.1.2 and Roon Arc 1.0.45 build 226.

Any way to fix this? The app is completely useless to me at present- super disappointing. Thanks.

I’ve moved your post from an existing Support request into a Support request of its own, so that the Support team can better diagnose your issue.

Please add the following information to your post to give full information and aid diagnosis. Thank you.

Roon Server Machine

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

1 Like

A post was split to a new topic: ARC Passes Port Test but Won’t Connect

Thank you for accepting my post. Here is the information you requested:

Roon core is an Innuos Zenith Mk.3 Music Server running Roon Version 2.0
ISP: Verizon (fios)
Routers: Primary Verizon (no model number indicated) connected to another secondary Verizon router, model E3200
Modem: Verizon connected to a Nokia box of some sort
Switch: There is an Ethernet tp-link model tl-sg105 switch between the music server and the secondary Verizon router
There are no VPNs or special security hardware on the network.

Hi @PETER_GARAFOLA,

Thank you for your post. The above switch in your description is a “smart” switch, meaning it’s capable of directing and filtering traffic passing to and from the ports. Since it’s positioned between your RoonServer install and the internet, it’s possibly restricting bandwidth for the upstream connection to ARC, or otherwise interfering.

  1. Try bypassing this switch entirely and hardwiring your RoonServer machine to the main upstream router. Are you able to connect via cellular data in this condition?

  2. If you’re unable to relocate the Innuos to bypass the switch, then I recommend prioritizing the RoonServer static IP in any QoS settings on the TP-Link switch.

  1. Either of these routers could similarly be throttling bandwidth for the upstream connection to ARC. If there are any QoS or related settings in the web administration page for these routers, verify that they aren’t interfering with RoonServer.

We’ll proceed from there. Thanks!

I was able to bypass the switch by connecting the music server directly to the network extender (the second Verizon router) with an ethernet cable. RoonARC works fine over the home wifi (as it did before) with this connection. It still does not work over 5g in the home. I will find a local establishment to test whether it works over the internet via a wifi connection away from home.

What is the required bandwidth needed for RoonARC to establish a connection to the core? Thank you.

Tested it from a remote WIFI network. RoonARC says the Roon Core is unreachable when accessing via WIFI. If I try to use the cell network (LTE) it says “poor connection”. In both cases it does not work at all. It will play cached content but I really wanted to be able to stream music just like at home. It only works when I am at home using my home wifi. I suppose it requires extremely high bandwidth. Is there any way to use buffering or down-sampling to get around this? ANy other possibilities?

Also just to be complete, in my Roon configuration it gives me the “Ready” message with a blue check, and it says “Your Roon Core was automatically configured and has been confirmed to be securely accessible by Roon ARC.” So it’s not an overall connectivity issue. It just does not work from outside my house.

Hello - After reinstalling Roon ARC on my iphone, and updating my roon core server as well as the Roon remote app on my iphone, the remote streaming to Roon ARC seems to be working. This is working both inside and outside my home over LTE as well as WiFi. Sound quality is good, no dropouts, and no noticeable latency. I will continue testing from different locations but for the time being this appears to be resolved. Thank you roon team.

Please prioritize an IOS version of RoonARC as soon as you can. Thanks.

Good to hear you’re up and running now with ARC.

I’m not sure what you mean by this … as ARC is already available for iPhones. Could you elaborate.

Also checkout the Feature Suggestions area, you might find an existing topic that covers your request … then you vote for it.

Sorry, my mistake. I meant the macOS.

No worries, iirc others have also requested a desktop version of ARC.