Roon ARC yet to work - Australia

Roon Core Machine

Linux (Zorin) on Apple Mac laptop

Networking Gear & Setup Details

Google Nest mesh router
D-Link VDSL modem

ISP: Aussie Broadband

ControlD DNS

Description of Issue -

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“121.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

No luck getting this working at all yet.
Port forwarding set up on both, static IP for the Roon core.
Modem will not work in bridge mode.
Plex works fine, Roon does not. Tempted to drop the subscription at this point!

Hi bjg,

It looks like your ISP uses CGNAT, see link

If this is the case you need to call them and opt out of CGNAT to use ARC. I think I saw a phone number in the page I linked.


If plex works why can’t Roon they just use UPnP and port forwarding to. What’s so special about Roons implementation that it just fails with setups that Plex works with effortlessly.

1 Like

Hi @bjg

I’ve posted many times on this forum about Aussie Broadband, as @Rugby posted, they use CG-NAT.

There are two ways to get ARC working whilst with ABB as your provider, pay extra for a static IP or call up their support and ask to opt out of CG-NAT, they will want a valid reason, tell them you have a service that requires Port Forwarding.

I’ve been through this process with Aussie Broadband so I know that it works.

My modem at the time was a D-Link Python DSL-2888A set up in bridge mode with an ASUS RT-AC88U handling the WAN and LAN routing.

I hope that helps you.


Hi @bjg,

Thank you for your patience and I’m sorry you’ve endured a long wait for an official response on your inquiry.

Aussie Broadband, as @oneofmany mentioned, has implemented carrier-grade network address translation. Depending on your account tier and geographic location, Aussie Broadband may simply be able to disable this feature for your account, enabling port forwarding. Another user’s success story is here: ARC not connecting to core on Asus RT-AC86U router - #17 by Jezep

@Simon_Arnold3, your question is by no means unwarranted. For a quick answer: Plex uses their own servers to do the heavy-lifting in circumstances where users must circumvent CG-NAT. There are several reasons why Roon has chosen a different implementation so far with the release of ARC. I recommend posting in Roon Software Discussion if you’d like to invite some clarification on this matter.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.