Roon attempts to play but skips tracks endlessly

I’m running Roon Core on an Intel NUC8i5, Windows 10 64, 16GB RAM. Connected to the NUC I have a Topping D10S USB DAC. This is set up as an audio playback zone in Roon.

For months, everything was working fine - when I play a track in Roon, the DAC displays the sample rate of the song and playback occurs normally.

As of this morning when I attempt to play a track, Roon attempts to play, then skips to the next track over and over until it reaches the end of the album. No playback occurs.

I changed no settings between it last working and now, and Windows has not updated. Roon updates automatically and is on the latest version.

The DAC is working fine - WASAPI output works as expected via Foobar2K. I have tried toggling Exclusive mode in the device settings in Roon, as well as the “Work around devices that misrepresent capabilities” toggle, to no avail. I’ve tried the DAC on another USB port, reinstalling DAC drivers, and rolling back Windows via System Restore. No luck. EDIT: Just tried another DAC entirely (Fiio Q3) and the default system Realtek output - does exactly the same thing. At this point, I can’t get any playback out of the Core machine regardless of output device.

However, playback works fine on other devices on the network - such as using Roon on my laptop and outputting to a SMSL DAC.

Any fixes here please?

Hi Abza,

I have had this problem in the past and it is very annoying particularly since it seemed to come and go .
For me it was networking. I bought a better router, which fixed it, and then I think I had in my new house recently and had to move the router slightly for a better signal. Whether the issue is capacity of the router or quality of signal I’m not sure. Cheers.

actualy Tidal is playing and Qobuz don’t work for me at time

everywhere comes the title is currently unavailable and too many glitches (only Qobuz)

I would reboot everything in the signal path. Shut it all down then reboot from the network equipment outward.
The symptoms are typically that of a network issue.

was a wise consideration, but if it doesn’t work after that only for Qobuz, the Roon team should take a look at your servers. Only what goes out there can arrive here. Qobuz itself is not down, only the functionality via Roon is missing.

Thanks for the suggestions everyone. I should have mentioned, but I only play tracks connected via external hard drive directly to my Core machine - no Qobuz or Tidal. So presumably networking shouldn’t be involved on a Core grabbing local music and outputting to a local DAC?

Regardless, I tried restarting my router (no luck) - it’s a pretty decent ASUS router as well, so unlikely to be the issue. Again, I can play music fine from other devices, streaming from the Core - so if anything, networking is working perfectly.

So this works fine:

  • Headphones →
  • SMSL Dac →
  • Macbook →
  • Roon Mac OS app →
  • Roon NUC Core →
  • Music on Hard Drive attached to Core

But this doesn’t:

  • Headphones →
  • Any output device on Roon NUC Core →
  • Music on Hard Drive attached to Core

Try updating to the latest Realtek drivers, they have caused your symptoms in the past. Did you add any software recently which might affect audio, gaming overlays, etc etc.

Personally, I don’t install the Realtek audio drivers at all and just go with MS HD Audio drivers.

Thanks @Rugby - tried updating, and uninstalling them entirely (and disabling in Windows). No luck

Haven’t installed anything at all in between it last working and now - was hoping this was a known Roon update issue or the like, but apparently not!

Just installed Audirvana on the Core machine - works flawlessly. Please Roon Lords, help me out here.

Hello @abza,

Thanks for detailing the issue so clearly and for engaging with our community to find a solution :pray: . Also, thanks to everyone for chiming in with suggestions :pray: .

Many times, Realtek drivers caused similar issues to yours. Could you please uninstall Realtek and reboot after? After a reboot, the default driver should be reinstalled. Does it work then?

Tried everything - including removing and reinstalling drivers. Afraid to say I had to wipe and reinstall Windows to get it all working again. Holding thumbs it was just a hiccup. Thanks again.

Hey @abza,

Thanks for the update! :crossed_fingers: Fingers crossed :slight_smile:

I had similar and endless problems with an Asus GTX-11000 router. Changed it to the Surfboard Modem and to a Netgrear Orbi router with 2 satellites. Haven’t had an issue since.