Roon Authorization Issue

Hi: After experiencing the exact same issue in terms of the Authorization Screen I wanted to know if this is a Roon client issue or is there some other way of handling this?

I have been using Roon for about 2+ years. This is new, although it more or less ties in to using the new iMac I have running as the Core. (see description below).

I connect to it with an iPhone 6, an iPad Mini 4 and the other older iMac. And most times, but not always wish to make the music selection on the core machine. So not sure if you say that machine is a Core and a Remote? Or is it considered just the Core? Not sure of the terminology used.

Does Roon’s technical team believe this was solved? It is kind of an old post so not sure if the newer Roon versions have tried to address it. In any case I still have the problem with

I have an iMac 27 inch (new). See uploaded file below for the description.

I was formerly using and still attached to the network an older iMac 21.5 inch. When I migrated from one machine to another I was getting the same request for Authorizations with nowhere to go other than to unauthorize the machine running the Roon Core.

So more or less before I saw this Community Post, I had Roon running fine, then it would not play any music, as if there was a failure to recognize the 3 zones I have. Sometimes it would not see the zones at all. Other times the zones would appear but could not play any music from them.

So Roon works fine for a bit. Then I shut it down overnight and it does not work in the morning. Get the authorization screed if I close the app and then try to use it later.

What is the fix? For me it is recurring issue, I have Roon app closed and then open it I have to reauthorize the computer.

I agree with the other posters, there is no way to get out of the authorization screen other than to deauthorize the core on the machine Roon is running on.

Thoughts? I am sure there was some solution since this thread was started.



Hello @Daniel_Greenberg,

Thanks for contacting us regarding this issue. Can you please confirm how you migrated from one machine to another? Have you by any chance used a backup software such as Time Machine? The reason being is that if Roon thinks these two machines are identical carbon-copies, this can cause the strange behavior that you’re seeing here.


Hello Noris and thanks for your attention.

When I got the new iMac home, I used Apple’s Migration Assistant from the utility folder to move my apps, settings and docs onto the new machine. It ran without issue. It took a few hours.

I do not remember if Roon ran, but I do not think so.

First I downloaded and installed the Roon Server App. Did not work. Then the Roon app. When I started the software, it added all of my titles back into Roon. that worked.

So at this point I have both Roon Server and Roon installed. Should I delete Roon Server?

All of the tracks are back. And the numbers seem to make sense on the Overview screen. A little high but I am not seeing too many duplicates in the library.



Here is another piece of information.

Tried to start up Roon today. Did not open and I could not play songs. Had left it on but not playing last evening.

Instead I got this message:

This is the same result others had in earlier posts on the same issue.

So the issue is that Roon could not restart when selected, given the app was on overnight but not playing.

With this message you have to deauthorize the Core and then reauthorize it. I do not believe that was the intention. I can get it to work if I close the app and shut down the computer. Then restart.


Suggest you do your screen shots using command shift 4 and just grab the roon window area…unless you are full screen in roon. You might want to delete that image and redo it or crop out your desktop

thanks wizardofoz. Nothing proprietary on the desktop. There are many ways to take screenshots on a Mac in Mojave.

The issue really is that to make Roon active again, you have to shut down the Core completely, then the computer and assign new zones as they have mostly disappeared. Once you resurrect the zones, it plays fine. But the zones should not disappear when Roon app is open and not playing. Kind of a pain to shut down the computer and put all of your details in again for the Zones…

Hello @Daniel_Greenberg,

I believe the issue may have started when you moved the Roon App using Apple’s Migration Assistant. I would suggest you perform a reinstall of Roon by using these instructions:

  • Create a Backup of your current database
  • Uninstall Roon
  • Make sure that your Database Location is completely empty
  • Re-install Roon
  • Restore your database from the backup

Please let me know if those instructions help.