Roon automatic backups... USB key unavailable (again!)

ROCK / NUC8i3 / Serial #1C697A03FBE1

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Fritz 3272 modem-router … the Fritz is one of the best available, all other equipment are connected without any problem… the NUC is connected via LAN Cat6.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB key, brand TDK, 8Gb

Description Of Issue

Hello Noris,

It is happening again… at the beginning the folder defined for automatic backup was inside the nas, the Fritz can also operate as NAS when there is a memory attached, and it was… then suddenly was not possible anymore, but at the beginning it was fine, and I got from you, I mean Roon support, suggestion to use a usb stick directly connected to NUC… so I’ve done and after a while I started receiving error messages about fault in scheduled backup activity… then the suggestion was to replace the usb stick with something with better quality, ok… done that in July, I mean three month ago… today this is the message I’m reading, please note that I’ve tried to select the folder by hand and this is the result (if I turn off/on the NUC the led on the USB key blinks… it means the usb is there also for the NUC, it is connected)

is it possible a usb stick last only three month (one of them off)?

I’ve doubt… if I define a maximum number of backups, let say ten, when all the ten are already there the backup procedure will overwrite the older one or will fail with a stupid message about “folder not available”?

Thks in advance

This sounds like the issue I was having . I will try and find my own thread on this for you

I have never been able to solve this so now I do a manual back up

Make that a trifecta+1.

that what I’ve tried too… but it is also not possible to create a new folder il the USB key … so the manual backup fail again even before to start

Roon restore/backup is not reliable is something not acceptable in my opinion, we are here not talking about a freeware software but something quite expensive … backup is very important to everybody having big libraries. If there is a problem has to fixed, can’t just be a lottery between nonsense change of USB key. IMHO this should be at top of priority in the TO DO list…

Noris, or another one of you colleagues, what should I do now? Suggestions?

1 Like

Yes I had to buy another usb drive to do this.
This is my third usb stick bought just to back up roon .
I think there are other ways you can back up roon but my knowledge of this is limited

so you mean you buy a new usb stick every three month? in a short time you will be able to resell in the market, you will have a stock like a dealer :frowning: … it makes no sense to me, the stick is fine… my windows7 pc is able to read it, the NUC recognise it … it has to work, if there is a problem has to be fixed

I agree it’s not satisfactory . I have not had a problem since starting to do manual back ups, but it’s not ideal as I often forget to back up for weeks
If it is affecting a lot of people then yes maybe roon should investigate this

I’m wondering how this could not affect many people… we all use the same software and, probably, most of us are using a NUC configurate exactly as from Roon specs, as I’ve done… do you think is possible there are only two people, me and you, facing this (not new) problem?

I am quite sure there will be more than me and you

anyway… waiting for the bug fix here is how to… just get the old usb stick you thought was broken, format to FAT32, insert into your NUC and, miracle, the backup works again… until next time

@Paolo_C, @Womaz -

If you followed the trail of my linked post, you will see that your problem is not the only problem with Backup/Restore.

The whole process is riddled with errors.

Not to downplay your problem, but there are more insidious problems than being told you can’t backup, e.g. saying a backup worked when it didn’t or backing up a corrupted library.

The problems with Backup/Restore are exacerbated by the fact that Roon insists their procedure be used rather than some tried and true backup software.

People need to realize the potential ramifications of these errors to the continued viability of their extensively curated libraries.

1 Like

If what you say is true this is very worrying. I just assumed that the back ups were actually working. In my case I just have a problem getting the automatic back up to work.

Wouldn’t lie to ya.

I backup up to multiple locations, with multiple retention periods, and on multiple schedules.

I check my backups every morning.

I have two incidents open with support.

You’re probably Ok. I can only tell what my experience has been.

1 Like

Hi @Paolo_C,

How is the USB stick formatted, is it using NTFS, FAT32, exFAT? Can you please access your ROCK logs by using these instructions and send me a set? I would like to take a look to see if there are any further clues contained in the logs, thanks!

ciao Noris,

sorry I’ve seen your post only now… yes for sure, tomorrow I will do that and send you the log

1 Like

Ciao Noris, in your hands you should already have a zip file with my logs, it is dated October 1st … so it should be fine as it is newer then my post in this thread, it should already contain the info you asking for… the name of the file is

(I’m having problems with that sh…t of Dropbox, Google Drive is so much better)

Hi @Paolo_C,

Please correct me if I am wrong, but there has been a network change since Oct 1st, and the logs you sent then would not be applicable any longer as per your other thread:

I’ll make an account for you on our diagnostics servers where you can upload the new log set, info sent via private message.

Ciao Noris,

no, there was a small misunderstandig in the other topic now closed, Fritz didn’t do anything to my modem-router and I didn’t change anything in my lan hardware… with “supplier” I meant (I wrote it but maybe not clear enough) the internet supplier, the company giving internet (adsl) access… they fixed the problem in their cabinet somewere and the line is stable now, nothing about my hardware or my lan

so, the log you have is still valid as nothing change in the meantime…
about the usb key… it is FAT32

if you need the new log ler me know

thks for help (as usual)

1 Like