Roon available zones are missing

Core Machine (Operating system/System info/Roon build number)

Mac OSX High Sierra 10.13.6
MacPro 3.1 / 2x2.8GHz Quad-Core / SSD OS / HDD DATA
Roon 1.6 (build 475) 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
AirPort Extreme ‘N’ dual band wireless router
Core connected via ethernet
Most output devices are connected via hardwire (except Apple HomePod)
TP-Link 16 port switch (TL-SG116)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Marantz AV7005 - Ethernet
Marantz AV8801 - Ethernet
Marantz AV8802 - Ethernet
Apple HomePod - Wireless
Oppo UPD-203 - Ethernet
Oppo UPD-205 - Ethernet
Apple Airport Express N (x2) - Ethernet
Apple TV 2nd gen (not used w/Roon)
Apple TV 3rd gen (not used w/Roon)
Apple TV 4th Gen HD - Ethernet
Apple TV 5th gen 4k - Ethernet

Description Of Issue

Audio zones come and go, somewhat randomly. Currently, I’m only able to see HomePod as an available source. Sometimes no devices are available. Later today, I will expect other and all devices will appear. I’ve tried re-booting core, router, cable modem, but nothing seems to correct the issue permanently.

Not sure if a setting is incorrect or an update to one of my devices is causing this new issue. Please help debug the root cause.

I’ve tried some debugging:

  1. created new Roon folder
  2. created new RAAT folder
  3. reboot cable modem, router, network switch, core machine

Consistently able to see HomePod (wireless) all wired connections are hit or miss.

@Junior77 Sam What are the DNS settings for your router and are all the devices using DHCP or FIXED IP addresses?

If the router is giving out DHCP based DNS settings then this could be the issue.

You should see something like this in you mac’s system prefs under network and advanced DNS tab if using DHCP or non greyed out if you are using FIXED

Ideally you should have your local router (APE) an ISP one and also ideally a public one (Google or CloudFlare) as you see here mine has all 3. If you only have 2 options try your local router and or

Using DHCP.

I have some unusual DNS server numbers.

Unable to delete these DNS values. Hmm…should I be concerned?

Hi @Junior77,

I wouldn’t focus on the DNS entries in your case here, I suspect this is a multicast issue and multicast traffic is not being properly passed through at one point in the chain.

I should note that we have often seen sub-par performance from Apple Airport routers, as mentioned in our Networking Best Practices. I can’t say for certain if this is the root cause, but it is one of the possible causes of the issues you’re seeing.

Are all of your Ethernet devices connected to this switch? What happens if you connect a few of your Marantz devices to the router instead of the switch, do they show up then? What about if they are connected via WiFi?

Well your Local DNS should be ok as it’s showing the APE, but as noted multicast would be the next place to focus. I dumped all my apple routers years ago and went to UniFi and have never looked back

All devices (wired) are connected via the switch. The switch is relatively new ~2months, but does seem highly suspicious.

The system previosly worked fine with no flaws, so something has obviously changed. Software settings or hardware failure- tbd.

I will connect one or two devices directly to the router and reboot all devices and report back the findings.

Is there a preferred brand & model for router that is 100% compatible?

1 Like

Generally we can’t recommend specific models, but we have found that standard consumer-grade routers perform the best (ASUS/TP-Link/Netgear/Mesh Style) and allow multicast to properly pass through. You can check out some Community recommendations in the following thread:

Do let us know how this goes.

Understand about not being able to specify a router.
I’ll review the community discussion.

Before I even messed with cables, I simply powered off/on my 16 port switch. Coincidentally, all devices were then viewable.

Is it safe to assume, with 100% certainty that it is a faulty switch or could there be some other unknown culprit, ie ape router.

It’s unusual for a switch to have a glitch, normally they work or they don’t. I’d leave all as it is and if it goes wrong again then start replacing equipment.

I just checked, no longer able to view wired devices.

Agreed…I ‘feel’ the switch is not the main culprit…but if I power cycle the switch I regain visibility of all my devices. So, logic would say it’s the switch.

When I have more time this afternoon, I’ll bypass the switch (Completely) and see what happens with the connection with using the router LAN ports as the only switch.


Good plan.

Connecting (1) AV and (1) airport express directly to my AirPort Extreme router, so far, so good. I’ll check back in a few more hours to see if it continues to hold up.

Odds of a switch failing in a couple of months? I guess it’s possible.

I still think there’s something else going on. I’d hate to purchase a new switch and end up with similar results.

Any good, reliable unmanaged 16port switch recommendations?? Lol

Hi @Junior77,

Glad to hear you’re on your way to narrowing the issue down to the switch.

There’s a thread for that too :slight_smile:

Update: Was still having good results with the switch out of the system.

I then decided to put back my previous (Older) 16port dlink switch. I’ve had no reoccurrence of the issue I was having. Assuming this lasts…the tplink switch failed in less than 2 months. Shame…it seemed to be a robust, compact, metal housing switch. Too bad it couldn’t be a little more reliable. I wonder what the warranty/replacement hustle will be.

Thank-you everyone for your help in troubleshooting. I’ll be sure to follow up if anything changes.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.