Roon Backup always fails

Roon Core Machine

Mac Mini 2012 i7, 16GB RAM, 275GB SSD, OSX Catalina.

Networking Gear & Setup Details

Not relevant.

Connected Audio Devices

Not relevant.

Number of Tracks in Library

20k+

Description of Issue

I have never managed to get Roon to backup its library - I have tried a 95GB partition on internal SSD, external plugged in 128GB flash drive. I set it ages ago to backup every few days and realised that it never has! Manual backups fail, see screenshot.

Screenshot 2022-08-02 at 16.44.05

Screenshot 2022-08-02 at 16.32.52

Restarting Roon and the machine doesn’t help.

Your screenshot failed to load

Does the MacMini have sleep enabled? Does Roon have permission to access the drive? How much free space is available on the drive?

Incidentally, a flash drive isn’t suitable for backups. Only use SSD and HDD.

Hi Martin, I’ve fixed it for the OP.

1 Like

Have you checked that the “read/write” permissions are set correctly for the locations you are trying to back-up to?

A test would be to make sure you can save a file to the location and that you can delete a file from the location.

I am not a MAC guy so maybe someone else can chime in to tell you how to set the attributes of the locations?

I worked on a similar issue for a Mac Core user earlier this year. What he ended up doing is backing up to his Mac using an internal directory on the Mac HD/SSD, and then copying the RoonBackup directory to an external drive.

FWIW, this is what I do also on my MacBook and I never have an issue. I have restored from both types of drives (internal Mac and external USB) and the backup always works during the restore process.

Martin, thanks for replying, the drives are empty. Roon


DB folder is written to the drives but then it fails.

As you can see this latest drive has read and write set to everyone. You can see its writes something to this drive which has 28GB free

Screenshot 2022-08-02 at 20.09.39

I tried again on a drive with 150gb free… same result.

Robert_F - I tried that too, same result!

Also check that Roon has Full Disk Access enabled under System Preference, Privacy.

I ddi this - it was unticked. I then restarted Roon and it once again failed.

Two other items. How much free disk space do you have on the Mac’s drive? I can’t tell of Server Data is local or attached. Second, it may be worthwhile to reinstall Roon with the latest download, but this may affect what is currently backed up.

Server data is a local partition of the SSD inside machine. it has 150gb free. I’d hop
e that was enough!

I tried a manual backup, several times, and it was stopped due to corrupt jpegs. I am now “re-analysing” all my albums which I expect will take hours!

I have now after days of fiddling about finally achieved a backup.

The process to solve this was to try to make a manual backup, when it failed the Mac OS told me what was wrong - corrupt jpegs - Roon did not.
I then deleted the jpeg each time the Mac found a corrupt jpeg.

I also used Roon to “Re-analyse” the albums which took days - but still didn’t fix the problem.

So to make a manual backup.
0. QIT ROON!

  1. Go to finder hold down alt/option click on GO and select LIBRARY (Library only appears if you push alt/option)

  2. Find ROON folder, drag copy this to you backup destination.

  3. The Mac starts to do this until it finds a corrupt file. Copy the name of the corrupt file and search for it in the Library finder window, it will appear and they’ll be two - you can try to delete them both though it will appear as though only one is deleted.

  4. Back to square one, drag copy Roon again, wait for next interruption and repeat until all the corrupt jpgs are deleted.

Only then when a manual copy worked was I able to use the Roon copy mechanism.

So the real issue here is that ROON fails to backup but doesn’t tell us why.

How on earth could you solve this on a Rock/NUC or Nucleus?