Roon backup to USB thumb drive

Core Machine (Operating system/System info/Roon build number)

Nucleus +

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB Thumb drive for backup

Description Of Issue

Hi. I’m trying to set up a USB thumb drive to serve as backup. I am able to find the drive under Backup Location, but when I select the drive and click save, I get an error “Failed to get Authorization to Access your Account”. I have allowed “everyone” to read/write to the drive. Can I use a USB thumb drive for back-up purposes? Does it have to be formatted in a certain way before I use it?

I am interested in this method of backup, too.

Hello @Eugene_Choung,

Welcome to the forum. How is the external USB drive currently formatted? I am not aware of any specific format you should be using, except for avoiding using HFS+ (Mac OS format) as this format is read-only on Nucleus.

Thanks. The drive did indeed come initially formatted as Mac OS Extended (Journaled), which I believe is HFS+ and it did not work. I reformatted the drive to ExFAT and then to MS-DOS FAT - neither of which worked. The other offered formats on the Mac Disc Utility application are variations of APFS and Mac OS Extended, which I did not try. In each case, I created a folder called Backups and made sure that the folder was readable and writeable to “everyone”. Any insight or thoughts would be greatly appreciated.

Please clarify, you are trying to backup the Roon Core database to a USB thumb drive connected to a Mac?

Sorry if I wasn’t clear, but the USB thumb drive is plugged into one of the two available USB ports in the back of my Nucleus +. Thanks.

Hello @Eugene_Choung,

  • Have you rebooted the Nucleus?
  • What kind of drive is this, can you let me know the model/manufacturer?
  • If you have another PC around the house, can you try formatting it with the other PC?
  • Do you have another USB drive that you can try to verify if the behavior is the same?
  • I have rebooted the Nucleus and am getting the same result.
  • I am using a SanDisk 64GB Dual Drive USB-C.
  • I do not have another PC in the house, we only use Macs here. The USB drive (on multiple formats) works on everything but the Nucleus. Also, to be clear, the Nucleus recognizes the USB drive, but it gives me an access error when I try to use it as the back-up drive.
  • I do not have another USB thumb drive. I bought this one from the Apple Store earlier this week with the hopes of specifically using it for backing up my Roon.

Thanks. I appreciate all the help here, but I may just back this up to DropBox if all else fails.

Hello @Eugene_Choung,

Just to confirm here, you are using the USB-A output from the Sandisk and not the USB-C, correct?
If so, I would like to take a look at diagnostics for when this behavior occurs on your end.

Can I please ask you to reproduce this issue once more and note the exact local time + date when you are presented with this error message? E.g. 4:24PM on 8/29/19? Once I have this info I can enable diagnostics and see if there is perhaps any additional info contained in them.


Yes, that’s correct - I am using USB-A. My understanding is the the USB-C connection on the Nucleus is not in use at this time.

I reproduced the issue at 4:13pm on 8/30/19. Specifically, I attempted to add the “Backup” folder on my thumb drive to Backups and got the error “Failed to get authorization to access your account”. Backup location is stated as Nucleus+ > ULTRA USB 3 > Backups.

I did manage to backup to my Dropbox account in the meantime.


Hi @Eugene_Choung,

Thanks for providing that timestamp. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once these are received, I will be passing them to QA for closer inspection and adding them to the review queue. I will be sure to let you know once I have more information to share, thanks!

3 posts were split to a new topic: Nucleus Failing to Power On

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.