ROON Backup writing hidden files to disk drive which cannot be deleted

Not sure how support work on this site but this issue has been with me for some time, and apparently others, and I see the thread that pointed it out is slowly moving down the long list of requests. Your attention requested.

Thanks

Have a very similar problem…had posted earlier on about formatting a ROCK attached flash drive as I assumed the drive was at fault…store replaced the drive which worked for, say, two weeks and now has an invisible directroy. Booted to recovery mode and the drive cannot be formatted as was the same case with the earlier Lexar usb drive. Backups work and then apparently write to an invisible directory. As a consequence these little Lexar 32Gb flash drives have an unreadable directory and the drive cannot be written to nor formatted. The directory shows itself on the “pie chart”but a hidden bit of data.
Sorry, not as computer savy as some of the poster in the thread above but this is the second flash drive now “possessed” by something ROON has written to it.
Surely OS recovery mode should be able to overwrite the drive but not the case, not this time, nor in my earlier drive failure. In the first instance used the terminal window but the drive was unwritable.
I have inserted a third USB drive to see if this behaviour can be replicated on a differing make of drive.
Latest software for Roon and Rock.

In my case a small 32Gb usb flash drive is solely dedicated to a ROON Backup. So the problem is even more evident as this hidden directory cannot be deleted nor the disc reformatted as the OS reads it as “unmountable” and “in use”. This even when using Terminal or Recovery Mode in OS.
I suspect the posters noticing this issue but using large drives will also have an unreadable directory which will have a similar footprint…unreadable, undetectable and not allowing disc formatting. Hope I am wrong on this one. his is the second Lexar USB drive that had this same problem. Had assumed the drive had failed and my merchant was kind enough to replace it on y word but this second event tells me it is likely in the software. Am trying a third drive from a differing manufacturer to see if the behaviour repeats. Seems to appear after a series of backups are made…a set of backups are visible but the dates are older than the more recent backups made.! Screenshot of hidden files which are, too date, undeletable…help from Support requested!

Hi @Wdw ---- Thank you for the feedback and my sincere apologies for the wait. I have went ahead and split your posts out to a new topic so we can address this behavior with you directly.

Moving forward, we are going to be doing some testing to try and get a better sense as to what could be causing this behavior. In light of this, would kindly verify the following for me:

  • Please provide the steps (procedurally speaking) as to how you got about creating your backups with the mentioned disk drive(s). Furthermore, please be sure to include where the drive is mounted when your backups are created. My assumption is that the disk drive is connected directly to the machine hosting ROCK, but due confirm.

  • From your report I can see you have tried a few disk drives while troubleshooting this issue. Have these devices been used for anything else or are they just being used for housing your backups?

-Eric

Hello Eric,

My thanks for your response. No worries about the delay…seems there are a few issues to attend to.

To your questions:

The drives in questions are solely dedicated to the ROON backups bought specifically for this use. The first, as mentioned was assumed to be faulty as the drive couldn’t be formatted after being used for backups. I wanted to reformat the drive as it finally never was available to ROON so wanted to wipe it clean and start anew. The second drive, replaced by the merchant, and put into use as the backup host drive has a similar footprint (see the hidden directory). Using terminal commands I cannot do anything with it…bear in mind terminal and higher order Mac OS stuff is not my forte but I can bash around with some success.



As you surmised, the flash drive is mounted directly to the NUC ROCK in the front usb slot. Backup is via scheduled backups…one a night and saving ten copies.
I am concerned this may be a larger problem but only manifest as my drive is single use and easy to attempt to format without consequence to other data n the drive. I question whether your hidden directories are resident on many other user’s drive.
Best

Thanks for the follow up and taking the time to answer my questions, very appreciated @Wdw.

As mentioned we are going to be doing some testing on our end and now that I have your exact work flow down along with the observations you have made, I will be updating/passing my report over to the tech staff for further analysis.

Once my report has been updated and passed back I will be sure to share the team’s thoughts/findings with you in a timely manor. Your continued patience is appreciated Warren!

-Eric

See below following screen shot showing the latest flash drive in use

and file backup library with hidden and non-hidden libraries…it appears there are two sets of the backup libraries ad265…

Hi @Wdw ----- Thank you again for your patience here while our team has been performing some in house testing using the information you have provided to us.

Moving forward, we have setup a similar configuration to your and thus far have not run into any issues while trying to delete previously created backups (or restoring from them as well). Here are the steps we followed:

  • formatted a 32gb flash drive FAT32
  • plugged it into ROCK
  • made a backup
  • shut down rock and removed the flash drive
  • plugged flash drive into Mac
  • confirmed i can restore from the empty folder
  • deleted the “empty” folder

Based on the above, is there anything we may have missed in our steps in comparison to your “work flow”? Furthermore, do you know what the mentioned flash drives are/were formatted to?

-Eric

OK, so are these series of Lexar drives I’ve used corrupted? (note, each was brand new)
For each I couldn’t delete the hidden files! Drives are formatted ExFAT. These messages generated when attempting to delete files.


I am also experiencing this issue, though on an Apple Time Capsule.

On the Time Capsule, on the top level of the RoonBackups folder, there are two sub-folders, one visible, the other not. Their names are identical, except for the “.” at the beginning of the invisible folder’s name. The file/folder heirarchy within each is identical, but the contents of the “backups” & “objects” folders differ.

The visible folder contains backup data to 10/15; the invisible from 10/16 to the present.

In Roon, if I go to Settings>Backups>Find Backups>Browse", and navigate to the visible backups folder, Roon displays only the backups to 10/15, but if I goto Settings>Backups>Scheduled Backups>View, select the Time Capsule backup, and then “Clean/Restore”, Roon lists all of the backups from both folders.

One more potentially related detail—The size of the invisible folder’s objects folder is much larger, 2.0GB vs 621MB. Yes, since 10/15 I have added tracks to my Roon library, but only 75, or about 8% of my library’s track total.

Hope this info is helpful.

Can you reformat the drives to FAT32?

Hi @Wdw — Thank you for touching base with me. I think it would be premature to assume that the drives are all corrupted.

I will be updating my report for additional testing now that we know the drives had been formatted to ExFAT. If possible, I would recommend try testing with a FAT32 formatted drive as suggested by Rugby, just to verify if the experience is any different.

-Eric

1 Like

The point is the drive in question cannot be formatted nor erased.

have you tried a 3rd party formatter like rufus?

No…never heard of it but will check it out. Tried diskutil in the terminal window, etc

Did you use Disk Utility that’s found in the Utilities Folder under Applications?

Click on the thumb drive on the left of the screen, then click Erase.

Cheers, Greg

@Eric have recently reconfigured my Roon setup and I now have 7 backups. I deleted all old backups from before the reconfig. The RoonBackups folder still contains over 18 000 folders, around 11 700 of them empty. It seems Roon doesn’t tidy up empty folders when I delete old backups.
Is this correct behaviour? Is this somehow related to the ‘cannot be deleted’ problem? I have a couple of images, but won’t upload unless it is deemed necessary

thanks but tried that route at the very beginning.

@Eric There is something written to this drive by ROON backup (perhaps it is from an earlier iteration) that simply cannot be deleted (at least at my skill level).
See the following list of commands attempted within Terminal

…erase…cannot unmount…unmount successful…erase…cannot unmount…

You might try reviewing this link to see if it helps:

https://discussions.apple.com/thread/4865361?start=0&tstart=0