Roon Bridge NonFunctional on Fedora 30 Desktop

(Wayne Weddington) #1

Core Machine (Operating system/System info/Roon build number)

Dell PowerEdge 1950 Blade Server running Fedora 30

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired connection through ASUS RTN66U, also offers wireless DHCP

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Music is connected via USB (WesternDigital 1T SSD) to a desktop running Roon Bridge on Fedora 30 OS…

Description Of Issue

Roon Server is running fine, confirmed by Roon client running on my cellphone Blackberry KeyOne. But neither the Server, nor the Client is able to “see” the desktop computer (running Roon Bridge) where the music resides by SSD.

(Noris) #3

Hi @Wayne_Weddington,

What OS is the desktop computer running? Have you made sure to add Roon as an exception to any applicable firewalls on the desktop computer? Is the desktop computer also connected via Ethernet?

Since you mentioned having an Asus router here, can you please confirm that you have “Enable Multicast Routing” checked in your router settings? This aspect is mentioned in our Networking Best Practices Guide (along with a few other troubleshooting tips).

(Wayne Weddington) #4

Desktop OS Fedora 30 (in the thread title).

I have disabled the internal firewall entirely. The Computer is connected by Ethernet. I do not have “Enable Multicast Routing” as an option but there is a firewall option on the router that has a toggle “Filter Multicast.” Is that something I need to uncheck? If so, would that not increase the propensity for noise on the network?

W

(Noris) #5

Hi @Wayne_Weddington,

Just to clarify here, both RoonBridge & RoonServer are installed on the same machine? As per our Knowlege Base, RoonBridge is only for audio devices and not for library management. If they are both installed on the same PC RoonServer essentially has the same capabilities as RoonBridge + library management.

If RoonBridge is installed on another computer, would give the “Filter Multicast” option a try. If it is currently checked that indicates that some multicast aspects are filtered, and temporarily toggling this setting might allow Roon to connect, so I don’t see the harm in seeing if it helps.