Roon Bridge on BBB not recognized at startup

**Core Machine **

Intel Nuc I5, Linux, Roon 1.7 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired network, Static IP of Player and Core

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

BeagleBoneBlack (Gentooplayer Linux) with Botic Kernel connected by ethernet
Description Of Issue

I use the BBB as Roon-Bridge for some time now and everything worked well. It shows up under the Audio Tab of settings.

After adding ShairportSync Software to reach my BBB via Airplay only an ShairportSync Instance of the BBB shows up in the Audio Tab (and is usable if activated) but the Roon-Bridge instance is not showing up any more under -->Settings–>Audio–>
It is still listed under -->Settings–>About–> as Roon-Bridge.So both player instances are seen by the server but the Ronn-Bridge part is not “mounted”?
If I restrart the Roon-bridge on BBB via console a few times it shows up again and is working. Also if I disable the ShairportSync process via console.
If I disable ShairportSync and wait till Roon-Bridge is up I am able to start the ShairportSync again and booth stay up and running. But only till next restart.

thx

Branko

Hi @Branko_Tokic,

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

Hi Dylan,

I do not use Dropbox or similar software. How to submit the Log files?

Branko

Hi @Branko_Tokic ,

I’ve sent you a link via private message on where you can upload logs. It may take a bit of time to look into this issue due to the release queue, but if disabling Shariport mitigates it, please leave Shariport disabled for the time being, thanks!

Hi,
today I uploads the Log-Files together with some screenshots I made an s description when the screenshots where made.
There a two player instances running on the same BBB: 1. Roon-Bridge (Linux-botic) and 2. ShaiportSync.

After starting the BBB ShairportSync show up almost immediately under “Other network Devises” The Ronn-Bridge only shows up under “–>Settings–>About–>” but not under “–>Settings–>Audio–>Other-Network-Devices”
Only if I stop the ShiarportSync Process (via console) the Roon-Bridge Device shows up under “Other Network Devices” and the playing Zone could be started.
After that if I restart the ShairportSync process booth devices a there an can be used as it should.

regards
Branko

I also believe this problem occured first after Roon Version 1.5
Before both player instances occurred immediately under “Other Network Devices” and could be used.
Branko

Hello @Branko_Tokic,

Can you please confirm if you are still seeing the same behavior in our latest Roon release? We have made a fix to zones appearing that may have helped, if the issue is resolved or has remained the same, please let us know, thanks!

Hi,
just installed Version 1.8 (Build 763) stable.
Unfortunately the problem remains the same :frowning:

Branko

Hello,
also after installing version 1.8 build 764 the problem is still here.
All Airplay devices are listed almost immediately under other network devices with correct IP address.

The Ronn Bridge (BBB) is recognized some time later (with same IP address as the Airplay device running on this BBB) but then not listed under Audio devices till I stop the Airplay on this same device.

BR
Branko

Hello @Branko_Tokic,

RoonBridge (aka RAATServer) will only expose audio devices that are available for playback.

If Shairport-Sync is hogging the ALSA device, there’s nothing Roon can do until it releases control.

I can’t tell you how to achieve this, but I can foresee a few options:

A) Prevent Shairport-Sync from hogging the ALSA device.
B) Figure out how to get Shairport-Sync to release the audio device immeditely when playback is finished.
C) Expose different ALSA virtual audio devices to Shairport-Sync and RAATServer and handle conflicts in your own code.
D) Create a script to easily flip between Shairport-Sync mode and RoonBridge mode.

-John

Hi,

Shairport-sync is not hogging the alsa device after startup as far as I know. It is only active (hoging) while playback.
There is no problem with switching playback over Roon-Bridge device (BBB) or Shairport-sync once booth are running…
The problem is how Roon recognizes the audio-devices at start of the BBB. Before Roon-Version1.5.x everything worked OK with the same setup.

Branko