Roon Bridge OS X not working [Solved]

I have RoonCore 1.2 running on a MacBook Pro / OS X 10.8 (upgraded from Roon 1.1) and controlling from an iPad. Everything is working great, as expected. Thanks for the great work.
Then I installed RoonBridge on an iMac / OS X 10.11 (was working reliable as RoonClient under Roon 1.1) and started the app (RoonBridge Status = running). My core (and my iPad Air Control) can’t see RoonBridge on the iMac. No software firewalls or other audio apps running on both systems. Restarting everything doesn’t help.
After that i upgraded Roon 1.1 on the iMac to 1.2. Roon 1.2 on iMac connects to RoonCore but can’t output music to local USB DAC and/or own system output (worked under Roon 1.1). But it can output music to the Core.
Then I quit Roon on iMac, deleted Roon folder in ~Library/ , restarted Roon and selected to access my RoonCore. No change. Deleted Roon folder in ~Library/ again and restarted Roon and set up an new Core on iMac. To my surprise I now have two cores in one network, working simultaneously, access the same network folder on a qnap NAS and playing music to an Auralic Aries mini via AirPlay (not simultaneously – but one after another works well). But they don’t see each others Audio devices in Settings/Audio. Refreshing/restarting doesn’t work.
Screen shot MacBook Pro:

Screen shot iMac:

Screen shot iMac RoonBridge Status on iMac:

Screen shot iPad (connected to Core on MacBook Pro / RoonBridge visible that is not accessible via Audio Settings)

What shall I do to be able to play music from RoonCore on MacBook Pro on iMac (controlled via iPad, MacBook Pro)?

If I understand correctly, there may be a problem running both RoonRemote (now core) and RoonBridge on the iMac at the same time.

First, do you need to ever use the iMac to control Roon? If no, and just need it as an endpoint, then uninstall Roon on the iMac completely and just install RoonBridge.

If yes, the only install RoonRemote. You don’t need RoonBridge.

Hope that helps.

Cheers, Greg

Thank you Greg

I uninstalled and deleted Roon folder in ~Library/ on iMac. Restarted iMac. Opened on iMac. RoonBridge Status = running. Restarted RoonCore on MacBook Pro.

No change. I can’t see RoonBridge-iMac in Settings:Audio on RoonCore on MacBook Pro.

Cheers, Markus

Hi Markus,

Your Macs aren’t seeing each other, so it’s got to be a networking issue. Funny though, the screenshots above show that your iPad is seeing RoonBridge.

Let’s get @mike to take a look.

Cheers, Greg

FileSharing and ScreenSharing works…

And a Portscan from my MacBook Pro (RoonCore) to the IP address of my iMac (RoonBridge) shows several open ports. Which port(s) is(/are) used by RoonBridge?

I’m not sure about the ports.

One last thing I can think of is to:

  1. Make sure firewalls are off on both computers
  2. Close RoonBridge on the iMac and rename all the Roon folders in your ~Library. With RoonBridge, there should only be RAATServer and RoonBridge. Rename them and also Roon and RoonServer, if they’re still around.

Restart RoonBridge and see if you can now see the iMac under audio settings.

If not, there will be a software update later this week that may or may not help with this issue. You might want to wait to see if it helps.

Cheers, Greg

Thank you Greg.

I will have to wait for the upgrade. I checked/tried every step…

Cheers, Markus

Hi Markus,

There’s a new build of the software released. Version 1.2 Build 128.

After you install it, can you see if you’re problem is solved?

Cheers, Greg

Hi Greg

I updated RonnCore on MacBook Pro to Build 128. Deleted everything (,, 3 Folders) from ~Library/ from iMac. Installed Roon 1.2 (Build 128) on iMac. Restarted everything: Router, Ethernet Switch, Macs.

Unfortunately no change. On iMac there are no Audio Devices visible in RoonRemote. Neither on the iMac itself nor on the MacBook Pro RoonCore (iMac RoonRemote not visible from RoonCore). Only Audio Devices of RoonCore and my Aries mini via AirPlay are visible and accessible from both Macs.

Screenshot RoonCore on MacBook Pro:

Screenshot RoonRemote on iMac:

Roon Library of RoonCore is working on both Macs.

Everything on Gigabit-Ethernet. No more WiFi. Audiofiles on QNAP.

With Roon Version 1.1 everything worked (with the limitation of the then private audio device of the RoonRemote). I could listen to music on both systems.

How to proceed? I had plans to end my tests and integrate my main rig with a Weiss DAC by means of the upcoming MicroRendu. Doesn’t look very promising at the moment.

Cheers Markus

Hi Markus,

I’m assuming you have an ifi dac attached to each computer. That was causing me some confusion.

I think there must be some network setting causing a problem. On the iMac screenshot, you should also see “Connected to Core” and the outputs showing on the MacBook. And vice versa.

I’m going to ask @mike to look into this. I’m confused.

Cheers, Greg

Thanks Greg

Yes, I have 2 iFi USB-DACs, one on the Core and one on the Remote.

Looking forward to provide @Mike with everything he needs to solve the problem.

Cheers, Markus

Hey @kon,

Let me first clarify your setup:
Your MacBook Pro (MBP) has a Roon app which is set up as a Core; iMac has: Roon app which is also set as a Core and another instance of Roon which is set as a Remote. right ?

Now, few additional questions:

  1. Did you use a backup of the RoonCore from MBP when you were doing the steps from the quote above?

  2. On the iMac open Settings > Go to General tab > Press ‘Disconnect’ button (‘Chose your library’ screen should appear) > Press ‘Continue’ button under the text ‘I want to use this PC as a remote control’
    Can you tell me what do you see there ? (or make a screenshot)

  3. Can you please repeat steps from my second question with RoonRemote on the iMac and describe what did you saw there? (or make a screenshot)

Thanks in advance.

Hey @vova

No. I have a MacBook Pro (MBP) OS X 10.8.5 with Roon Core 1.2 (Build 128) and an iMac OS X 10.11 with Roon as a Remote. In Roon 1.2 are no audio devices of the iMac visible – no matter what i try. With Roon 1.1 everything worked as expected.

I don’t want a core on the iMac. I’d like to keep my core on the MacBook Pro (and plan to setup a new core on a skylake-NUC or a Lenovo all-in-one with touchscreen in the next months). The iMac is downstairs and should run as a bridge and/or a remote.

On to your questions:

  1. I did not change anything on my core on MacBook Pro other than upgrading to the new builds. This core is up and running since may 2015, the day OS X 10.8 had been supported.

Did that before – an now repeated again. No change.

I have only one iMac. See 2.

Thanks for your support. Hope to clear things up.


Hey @vova

I got it working for good.

I created a new user on iMac. After logging in and starting Roon as Remote and/or RoonBridge everything works as expected:

I went back to the non working user and tried to fix it (disabling most everything, deleting extensions, …) but didn’t manage to find out, what the problem is.

I will log in as new user on iMac to access Roon.

Sorry for the fuss and thanks for your support. Keep up the good work.

Cheers, Markus

Thanks for info @kon. Let us know if this appear again