Roon Bridges Not Visible in About Screen

Roon Core Version 1.8 Build 918
Roon Bridge Version 1.8 Build 918

Rooncore - SGC i9
RoonBridges: Aries LE, Allo USB Signature, Innuos Zenith II
All Ethernet Connected

I cannot see either my Aries or Allo USB Signature Roon Bridges in the About Screen

Your last update claimed to fix this.

  • Fixed a regression in which Roon Bridge was not visible in the Settings → About screen after update to build 913

Same here. Had to factory reset my Zen Streams and Ropieee to get them back. Waited for this update but it didn’t fix it. All done now. :cry:

It did. Unfortunately, in some cases RoonBridge needs to be reinstalled in order for everything to come back correctly. Your bridges should have a mechanism to perform a reinstall or reflash. Once that’s done you’ll see Roon back in Settings → About.

1 Like

Your fix is to make me reflash 6 RoPieees?

1 Like

Doing a factory reset on the Aries LE did not work. I do still see it as an audio device. I have not figured out the Allo yet. Gave up and used the Ethernet card on my PS Audio Direct Stream. That does not show as a Bridge device. Both those devices run proprietary software so I am less concerned.

You may know already, but the latest (non-XL) RoPieee version allows force reinstall of Roon Bridge without reflashing RoPieee.

1 Like

We are very sorry for the inconvenience, but on some devices the code got into a state where it was no longer possible to take an automatic update although it still functions normally otherwise. Unfortunately, the only solution in this case is to reload RoonBridge. On most operating systems this is just a matter fr re-running the installer, but some of the Pi-based distributions don’t provide that functionality.

I have a number of different ropieee endpoints and all updated no issues to the bridge 918 build. These include stable and beta releases as well as NG builds.

You might want to send a feedback to Harry on a couple to see if there is some issue.

I’m trying to recover my 3 cubox-i roonbridges. I’ve reflashed one with armbian and then attempted to use the easy installer with this result:
Putty Capture
When I try to click on the easy installer link from Firefox I get a security warning and no download. I’m over my head here; Help!

Milton, there are several other active threads today where this problem has been explained. In short, Roon has switched to Cloudflare as CDN for downloads, and the new URL now is instead of

In the install script you have downloaded there is a curl command which downloads the actual tar file at install time. This curl command misses the -L switch and doesn’t follow a redirect to the new download URL. Therefore, the installer fails.

So, you have two options: First, you can edit the downloaded install script and add the -L switch to the curl command; or, second, just delete the install script and download again. I think Roon in the meantime has inserted the missing -L switch in the script.

Thanks Andreas. I found Spockfish’s thread and re-downloaded the script and it all appeared to work. Unfortunately I still can’t see the CuBox bridge on the About screen and Audio screen. So I think @support still has work to do…

Probably a pointless suggestion but, have you rebooted your Roon core and the endpoints after updating the Roon bridge components?

Not pointless. I’ve restarted Roon to no avail. Just about to reboot my core machine. Thanks.
Edit- No joy. Still no sign of the updated CuBox. Sigh.

Re-flashed the chip and reinstalled RoonBridge. This time it worked! I didn’t hook up the DAC until it was finished this time; don’t know if that made a difference…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.