Roon cannot be installed on MacOS on a Mac Mini M1, but works on Windows OS on the same Mac Mini

unable to run roon 1.8 on my Mac mini m1 with macOS Big Sur

Terminal shows need 64bit support

try to work it on Parallel desktop windows 10 on same Mac mini

and it works all right


Thanks so much for getting in touch about this and sorry about the trouble.

Just to make sure we understand correctly, on the same Mac Mini, you have MacOS and Windows OS installed. The Windows Roon software version works, but not the Mac version. Is that correct?

Normally, RoonServer is installed on a Mac Mini (headless). Have you tried that install?

Yes that’s correct

I used roon Mac version on this Mac mini just fine until 1.8 version

tried roon server
Terminal shows Warn: get lock file path: /tmp/.rnsgem501-
截圖 2021-07-09 09.28.09

ok now I can remote my mac mini roon server from my iphone
and play music from mac mini
still can not run roon app on my mac mini through

I have a similar issue but just on the Macbook Pro

This is the second related topic pending reply from Roon @support (this one since August 2021). Does Roon work as it should on a Mac Mini M1 or not please?

@Highfi - Yes, Roon should work ok on a Mac Mini M1. These users might have an installation issue, I would advise trying to reinstall Roon by setting the old database aside and installing fresh:

  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.