Roon cannot connect to Lumin D2 or cannot see it

Core Machine (Operating system/System info/Roon build number)

TEXT GOES HERE

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TEXT GOES HERE
Roon doesn’t connect to Lumin D2 suddenly
How can this is issue be resolved

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)

TEXT GOES HERE

Description Of Issue

TEXT GOES HERE

Please use Lumin app and disable Roon Ready, then enable it again. You can disable Lumin Streaming if you don’t use AirPlay, and Spotify Connect if you don’t use it.

If this does not work, please power off Lumin D2, power cycle Roon Core machine, wait for a few minutes for the Roon Core to start, then power on Lumin D2 again.

If this still does not work, please power off everything on the whole network including Roon Core, Lumin and iPad. Power cycle the WiFi router and all access points and network switches. Wait for a few minutes, then power on Roon Core and NAS (if you have). Wait some more, then power on the rest of the network.

In Roon Audio setup, you should see Lumin D2 under networked Roon Ready devices.

Please state the brand and model of your WiFi router, access points, network switches, powerline adapters, wireless adapters, etc. in the network infrastructure.

And state the brand and model of the machine running Roon Core.

1 Like

Hello Peter and Roon,
Room can not see my Lumin D2. When open Roon on the core, an iMac, with the Lumin D2 powered on it is not listed in the System Outputs. Thei problem happens all the time.

Please use Lumin app to turn on Roon Ready setting for Lumin D2.

In iMac, turn off firewall and any internet security. Go to settings for audio, find Lumin D2 under Roon Ready device and enable it.

Please describe your network topology, especially brand and model of all router, WiFi access point, powerline adapters, etc. Is your iMac wired or wireless?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.