Roon cannot connect to Lumin T2

QNAP 872xt

Networking Gear & Setup Details

Using eero as the gateway.NAS is plugged directly into the eero. The Lumin is plugged directly into another eero. This arrangement previously worked.

Connected Audio Devices

Lumin T2
Sonos - they all are able to be controlled by roon. Not the Lumin

Number of Tracks in Library


Description of Issue

Roon does not play on the Lumin T@. On the iPad, it shows that the device is selected and that music is playing. However, the Lumin display does not change and the music does not play. The Lumin is working correclty wihen I use their app to play music.

This set up has worked previously.
Private zone off
MQA decoder and renderer, previously tried decode only
Resync 0ms
Have tried to identify the device - HDA Intel PCH HDMI 0
Have two profiles for this device - only 1 enabled/tried both and neither worked.
Both show as connected to the core and not in roon tested section
Roon version 1.8 - 952 installed on core and tablets

In Lumin app, please enable Roon Ready.

In Roon, settings → Audio, find Lumin under Roon Ready, enable it and assign it a zone name.

In Roon playback, change the zone to the newly assigned one.

This is the wrong device. It refers to your Roon Core, not Lumin.

This is the wrong section. Lumin is Roon Ready.

In Lumin app, please enable Roon Ready.

Ready was already enabled along with Lumin streaming

In Roon, settings → Audio, find Lumin under Roon Ready, enable it and assign it a zone name.

Under Audio, there is no Roon Ready section. I see Connected to the Core, Roon Tested, Squeezebox, and Other network devices. The only place the Lumin shows is under Connected to the Core.

In Roon playback, change the zone to the newly assigned one.
When I click on the Lumin T2 at the lower right hand corner, it doesn’t show me that option. It shows me zone information when I click on grouping. The Lumin in the connected to core section is configured as a private zone. I believe that it used to show that to me in the past. The only thing I can do there is change to a different device. When I have the Lumin selected and push play, it shows sound level activity but not on the device itself. The Roon does not control the Lumin. It does on all the Sonos devices.

Please shutdown your QNAP and Lumin. Power cycle the whole network of devices starting from all Eero. Wait for 5 minutes, then boot up the QNAP and Lumin.

You need to have Roon Ready in Roon settings → Audio otherwise this won’t work.

Done. I powered down the Lumin, eero, and QNAP. Roon ready was active. Powered back on. Still not showing Lumin or a section called Roon Ready only Roon tested. Still doesn’t work. All Sonos devices work.

How is your T2 connected?
I assume you have it on the network yes?

Please disable Firewall in both QNAP and eero.

Then reboot the QNAP and Lumin again.

I disabled the firewall in the eero unit. The T2 is hardwired into an eero. The QNAP is hardwired into the main eero. The roon core was already being seen by both the Lumin and Roon apps. There is no Roon Ready section in the app, The Lumin only shows in the connected section so that is the only place that I can select it.

Please show a screen capture of Roon settings → Audio with the Lumin entry.

In addition to the Eero, do you have a separate router (from ISP or purchased separately)?


I have a Comcast Business router. The QNAP is plugged directly into the eero and the Lumin is plugged directly into another eero unit.

Two things:

  1. Please set Eero to Bridge mode. Edit: Then power cycle all wired and wireless devices connected to the Eero

  2. Please turn off “Lumin Streaming” (AirPlay) in Lumin app. (If you don’t use Spotify Connect or Tidal Connect, please turn them off too.)

Eero is in bridge mode. Lumin app doesn’t show a Lumin to connect to. I could see it in non-bridged mode. Nothing changed in the roon app. Still doesn’t show a Roon Ready section.

Success. It took some time to repopulate but all seems to be good. Thank you

In view of this, for the sake of other users searching for Eero network problems, my current conclusion is that for the model of Eero that the OP uses, “Eero has to be put in bridge mode for Roon to work”. The same finding has been shown before in other threads.

Typically one may suspect the router to be the culprit for not passing multicast, but here we have Roon Core on one Eero unit and a Roon Endpoint on another Eero unit, and they could not be seen by RAAT multicast discovery, so the culprit here is Eero.

1 Like