Roon cannot discover any wireless device

Roon Core Machine

Roon Core installed through the automated script.
Deskmini H470 with 16GB of ram and Intel Pentium G6400.
OS is the latest Truenas Scale with an underlying Debian GNU/Linux 11 (bullseye).
The machine has K3S installed and running to run other containers.

Networking Gear & Setup Details

No firewall on routeur or the host machine.
No VPN is used. Host machine is connected through Ethernet to the network.
I am in France so there is no routeur. The Internet Box provided by the ISP already does a pretty good router.

Connected Audio Devices

I use Roon on my Mac (works) and Phone (works for arc and Roon remote)
I would like to use it on Apple TV and Nest appliances.

Number of Tracks in Library

7,949 tracks

Description of Issue

My Roon Core does not seem to discover my wireless devices.

When I open the Roon Remote app, in Settings → Audio section I do not see any devices except for the current device and the integrated HDMI output of my computer.

I tried to discover the device with my Mac, iPhone and iPad but nothings shows up. It is not a connectivity issue since I can AirPlay/Cast from other devices, only Roon does not see the devices.

I already tried to change the Wifi from 2,4Ghz to 5Ghz and vice-versa but nothing changed.

I double-check my firewall settings and it is not enabled right now.

I don’t know what to do anymore to debug the situation.

Help would be greatly appreciated.
Feel free to ask me more info about my setup if needed.

Additional EDIT: When both running Roon, my iPhone can find my Macbook.

So after a little bit of investigation, it seems that K3S is not the issue.
I tried to install a new core on a computer with K3S and Airplay/Cast devices are showing up.
Looks like truenas is causing trouble here.

1 Like


I appreciate your patience in awaiting a response from us here at Roon.

Can you verify whether or not there’s anything Roon support can help with? If not I will close this thread for us.


Yes Support Team, sure. Close the thread in which I receive neither help or advice to debug my situation from the room Support Team .
In case anyone stumble on the same problem, K3S prevents Roon to see remote devices. Once I uninstalled it, everything started working.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.