Roon cannot find KEF LS50 Wireless

Hi @support

Just subscribed to Roon [Version 1.4 (build 294) stable (64-bit)] last Christmas. Installed core on my Mac mini (late 2012) 8 Gb RAM running OS 10.12.6 (Sierra). I have the KEFs connected via USB direct on the Mac mini AND via ethernet to a D-Link Switch (DGS-108). The Mac mini is also directly connected to the D-Link Switch.

Connected to the switch is my Synology DS416j running DSM 6.1. I have my music mostly on the NAS but some of it are in the Mac.

The problem is that on initial install, the Roon could not immediately detect my KEFs, either on network or directly connected to my Mac mini. However, after one day, Roon detected the KEFs on USB, but not on network. I could play music from both my NAS and Mac quite happily through the KEFs. This lasted for a day. The next day, a power outage led to a full reboot of all my system (I usually leave the system running). Thereafter, Roon had to restart and I had to recover the library from backup. No problems there. But since then, Roon has not been able to detect my KEFs. iTunes and Audirvana had no problems detecting and playing music out of the KEFs.

Hope you can help, as I enjoyed my short-lived Roon experience and really want this to work.

Jeff

The KEF have to be on and switched to the wireless/ethernet connection to be detected by Roon. If you have it on USB then Roon will not see the ethernet connection because it’s not the active connection. Hope that helps.

Hi John,

Thanks. The KEFs are switched on, and I have tried to put them on the wireless/ethernet mode when I test them with Roon. Unfortunately, Roon still gives me the “No Audio Devices Found” message.

Have you updated the firmware in the KEF? I forget the current version number but you need to be running the latest version.

Yes, John. I only got my KEFs in late Dec 17, so we made sure it was updated with the latest firmware (Nov 17) at the showroom before we brought it home.

Ok. Next thing to check is that the KEF are on the same network as the rest of the system. By that I mean if your stream is on a 192.168.1.X system then the KEF also have to be on a 192.168.1.X system. Can you reach the KEF via the KEF app?

Can you “see” the KEF in settings/Audio in Roon? If so, Are they enabled?

Hi John, sorry for the delay, as I was off grid for a while.

I am not sure how to check if my stream is on the same network. How do I check that? Both my Mac mini (Roon Core), my NAS and my KEFs are connected directly by ethernet to the same switch. I can play my KEFs via the KEF app. It reads the NAS music with no problems via the app.

I can’t see the KEFs. Under Audio settings in Roon, I see a blank page. It used to show my KEFs, but as I explained, after a reset of my system, it has remained blank.

Not sure if you have already done this but it sounds like your system is running off the same network so that’s likely not the issue You mentioned it happened after a power outage. Have you tried rebooting everything? Be careful of the turn on order. Shut everything off and then start the switch and then the NAS and then the computer running the Roon core and then turn on the KEF. Give each turn on plenty of time to fully reboot.

Have you tried turning off Firewall on the Core?

Nope, no difference. Thanks John!

Oh yeah, that worked the magic Mike! For the first time I see the Kefs on Network. Now it is playing very well. Thank you so much!

How do I make sure this doesn’t make my Mac core less secure?

My Kef LS50Ws have not reliably worked on the ethernet connection via Roon for approximately the last 3 weeks. They sometimes play for a few seconds but then I get the Orange error message on Roon stating it has lost control of the audio device.

I have had to go back to the USB connection of the Ls50w’s which isn’t nearly as convenient.

I am usure whether it is a Roon or Windows problems but both are fully up to date.

The ethernet functionality for the ls50w’s brought real value to Roon from my perspective.

Regards Andrew

I was using Roon wireless and wired for weeks without a problem. Roon is installed just on a Macbook. I find the SQ to be better through optical out of my Mac though. Even better again is iPhone end point into USB on the Kef’s. But you really need a spare iPhone or iPad that you’re not currently using for anything else.