Roon cannot find music folder on NAS anymore

Core Machine (Operating system/System info/Roon build number)

ROCK on an Intel NUC i5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Roon has been working perfectly under this hardware configuration for a long time. all of a sudden, Roon can no longer find my music folder on a Synology NAS. When I try to add the network share it reports back to me “could not connect to share: Unauthorized”. Any ideas? I have read how to add music library in the knowledge base and it did not help.

Could you share a screenshot of Settings>Storage?

It seems some people have run into issues like this when the previous storage location was something like:

Using a fixed IP address will often help: \\\music where the IP is the location of your synology nas.
Another approach is to use something like

If neither of those work, it could be more complicated.


I have tried the following ways of naming the network share, which did not work.


I can access the network share through windows file explorer, so I know the NAS is functioning. So far I have tried rebooting the ROCK core, the NAS and the router, which did not help.



So you have two NAS, one is DS418 and one is DS918, based on your screenshots. One of these is at IP 192.168.109.
From your second screenshot it looks like DS418 is still connected since you can see the folders in Roon. That’s good.
Have you tried changing your password for the DS918 NAS in DSM? It would be good to have one without any special characters. While you are in the Control Panel check to make sure the permissions for that Shared Folder didn’t change for some reason.

I set up a new NAS password in DSM and it worked. Thanks for the help.

I have the impression that the sudden issue you got with your Synology NAS correspond to the update of the Synology DSM package. Got the same issue with Roon until I reboot the NAS or change some configuration on the NAS (like the password).

You can check in the notification of your NAS if you had an update around the time it broke.

Just food for thougts.

Hello @Luis_Puncel,

Glad to hear that you managed to resolve this issue with the password change! I would check to see if the Synology update was recently performed, there have been a few similar reports of this update negatively impacting SMB connections.

I would also like to inquire of one other aspect - did the previous password contain any special characters? Does the new password contain special characters as well? I am curious to know if perhaps with the update special characters in password names are not supported any longer.

Both the old and new passwords contain special characters, so that wasn’t the issue.

Now that I reconnected my library using the different login, all of my playlists are broken. Any ideas on how to solve that. Just to be clear, I didn’t change the password directly, I created a new user and password on the NAS that I signed in on.

Never mind about the playlists not matching. I got it worked out.

Hi @Luis_Puncel,

Thanks for clarifying that. Did you by any chance see a NAS update automatically performed in your notifications? Either way, glad to hear that you’re up and running again.

Yes. There was a NAS update automatically performed just before. That must have been it.

Don’t know if this is relevant, but I noticed that your shared folder “music” is written lowercase in all these examples. Your screenshot implies, it had a uppercase “M”:

Even though you have it sorted out by now, this might have been an issue as well.

1 Like

Thanks for all your help!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.