Roon cannot load page [Solved]

I am using a Roon Nucleus+ as my core. I connect via wifi to the core and it has worked fine previously.

Today, when i tried to fire up Roon, it asked me to login again (when in the past it simply fired up to my usual overview page) and when i tried to connect to the core, the Room symbol just keeps spinning and the that overview page never loads.

Please help.


Maybe reboot the router?

Reboot everything.

Hi @Melvin_Sng,

Sorry to hear about the trouble. If rebooting, as @xxx and @ged_hickman1 suggested, does not resolve this, would you please post a request in our Support category, so our technical team can help?

Thanks in advance,

Thanks Rebeka for coming back so quickly. I tried the reboot suggestion and even before posting but it didn’t work. But what did was I restarted the system via web interface and also restarted the Roon Database. Although that meant the library had to be reloaded, my Nucleus and Roon now works perfectly as it did before! Am very happy again.



1 Like

Hey @Melvin_Sng,

That’s so great to hear! Thank you for letting us know, not only that everything works, but also what helped resolve the issue.

Enjoy the music :musical_note:,

A post was split to a new topic: Unable to connect to Nucleus