Roon cannot log into Tidal


I can log into Tidal through the web, desktop app, and my iOS devices. Roon is the only thing that cannot seem to log in.

I saw a similar post and ran through the troubleshooting steps and still no joy. (There was no tidal_account file in the registry directory on my ROCK.)

Can’t figure out why ROCK is only device that cannot log into TIDAL.

Any suggestions welcome.


I forgot to note that I have verified the network connection (wired ethernet) to the the internet (disconnected ROCK and plugged laptop into the cable and verified I could get to the internet.

Hello @David_Hughes — Thanks for sharing your report!

For next troubleshooting steps, I recommend:

  1. Power cycling your Core machine.
  2. Deleting your TIDAL cache.

The above steps often yield positive results, but if you’re still unable to login let me know and we can troubleshoot further.



Thanks for the response. I tried those steps and still cannot log into TIDAL.

I have verified my TIDAL account and can log in via web, desktop app, and iOS app.

Things were working fine prior to Wednesday.

Hey @David_Hughes,

Thanks for the update. Since you mentioned before that you didn’t see tidal_account, may I ask that you please confirm that your TIDAL account is still active, as suggested here.


1 Like


My TIDAL account is active. I can log in and stream music using the iOS app, the Mac OS desktop app, and the TIDAL website.

Hi @David_Hughes — Thank you for checking that for me.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please verify directly on your ROCK that you have internet connectivity here? Can you also give me the exact error you are seeing when logging in to TIDAL?

Next, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you,


I am at the office now and cannot access my ROCK from here, but I verified the network connection the ROCK uses last night when I noticed the problem. Are there specific instructions on how to verify that the ROCK can get to the internet?

When I tried to log into TIDAL through Settings->Services, I get the Roon animated icon and it just sits and sits and sits. I can click away from that page. The longest I have let it sit was about 15 minutes.

I will complete the tasks you identified when I get home in about 4 hours (6:00 pm EST)

I have the same problem as of today - can’t login to Tidal was working fine a couple of days ago. Tidal App is fine on same machine.

Panic over - power cycling my server fixed it.



I’m home and can start troubleshooting. What’s the best way to check internet connectivity from the ROCK?

I have reproduced the problem. 17:02 Eastern US.


I just installed Roon on a laptop, de-authorized the ROCK (I have only 1 license) and was able to log into TIDAL immediately. It appears the issue is only on the ROCK. I ran update/re-install on the ROCK last night and that did not help, but at least I know I am up to date.

Reconnected to the ROCK and still having the problem.


Issue has gone away.

I power cycled server, switch, removed and reconnected network cable. ROCK able to authenticate with TIDAL now.

I will just attribute this to “gremlins”, though I used the ethernet cable from the server when I tried using the core on my laptop and everything worked. Go figure.

let me know if you still want to run more advanced diagnostics.

thanks for all your help

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.