Roon cannot use MacBooksPro System Output or Headphone Output, just internal speaker

Roon Core Machine

Mac Mini Mid 2011 16GB RAM, iCore 5 2,5GHz

Networking Gear & Setup Details

ZTE WLAN Router H388A, WiFi, Devolo Power /WiFi/LAN AC1200+

Connected Audio Devices

Macbook Pro 2019 16", 16GB, 6 Core icore 7, Auralic Aries, Resten MAMS+

Number of Tracks in Library

around 55.000

Description of Issue

I can switch in Roon Remote to Macbooks Pro System Output or Headphone but it cannot play (see screenshot)

When I switch to Macbooks Pro internal speakers it works

NOK System Output

OK internal speakers

System Info

Hi @Armin_Moesslacher ,

Thanks for reaching out! Can you please provide some more information as to how the Headphone or System Output zone does not play? Do you see any error messages displayed? Do you have any active firewalls on the affected Mac? Is the behavior the same if you try to temporarily disable any active firewalls?

Hi Armin,

Two observations:

On your Mac you can configure two different output devices: the standard device which uses the mixer (Standardgerät) and output via Coreaudio, which in the device setup should be configured with the ‘Exclusive mode’. This is the only device you should enable in Roon. You can use it both for playback from your Mac’s speakers and for digital Toslink output from the Mac’s headphones output, if your Mac model supports Toslink out.

I can see that you have both devices enabled with the same Roon device name. I don’t know if this causes any problem, but I suggest to disable the standard device or at least rename it.

Other than that, I am not sure what might be Microsoft Team Audio’s role in that, even if you haven’t enabled it in Roon. It seems to make use of Coreaudio, and if Microsoft Teams software is running on your Mac, it may take exclusive control of the Coreaudio device and prevent Roon from accessing Coreaudio.

No Firewall on the MAC Book Pro, no errors displayed. Just not working to enable Headphone output or system output (just MacBook Speakers)………

Also the Router has no blocked ports since Server and Remote are on the same privat LAN segment.

Very strange indeed, all other devices are working flawless like Auralic LE, Restek MAMS+ etc etc even local output on the server (Mac mini) is working if connected….

Best regards,



Thx I tried to play around with that, naming conventions and disabling the speakers and just enabling the system output, just no difference in the behavior.

Best regards,


You might be up to something here:

Hm, Teams is not used when Roon is though, might worth a try to unistall Teams and test…

BUT Spotify works flawless even with the MSTeams audio driver

with ps -ax I get:

Armins-MacBook-Pro:~ armin$ ps -ax | grep -i teams
312 ?? 0:00.96 Core Audio Driver (MSTeamsAudioDevice.driver)
3996 ttys000 0:00.00 grep -i teams
Armins-MacBook-Pro:~ armin$

So I also saw that even Teams was unistalled the driver files remained in the Library Folder and also the process, people had to remove/kill both manually

So I deinstalled Teams but problem remains see screenshots, when I choose Headphone play bar still grayed out… I also tried to group not working (then whole group not).

What’s the make and model of the headphone?

I don‘t know why this matters I tried 4 different with 3,5mm jack. It’s an AKG 702.

1 Like

Thank you for sharing this information. I just asked about it to avoid spending time researching possible but pointless for your case solutions.

Hello @Armin_Moesslacher ,

Thank you for that additional information. Can you please reproduce the error, note the exact local time + date + track when you tried to play in Roon, and let me know here? I can enable diagnostics mode for your account afterward. Also, did you use any backup software to restore one Mac to another, apps like Time Machine?

Hi! I can try in the next 20 min around 8 p.m. local time, and no no backup mode on my Server (MacMini) or MacBook Pro (but I can try to reinstall on the Macbook Pro)

So after uninstall, install Roon.dmg and enabling system output it works now…thx for the support!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.