Roon can't authorize with Tidal anymore

I’m getting a little desperate since I’ve tried everything I can think of and everything written on the forum on how to fix this problem.

The Problem:
I,as many others had the recurring login problem with Tidal since the last 2 updates of Roon server. At first it occured sometimes a week, escalating to every time I started Roon. So I tried other browsers for authentication on both macOS, Windows and Android, deleting cache, tidal settings files and every other trick found on this forum. Since it didn’t help I took the radical way by uninstalling Roon server and deleting everything on my disk and in the registry that had to do with Roon. Installed and scraped my library (Got a huge library, so I prefer not to do it again even though I have assigned all cores of my Ryzen 5 2400G to Roon on my Server it takes a really long time) and when it was finished I tried to connect to Tidal again, and there it was… a brand new problem…

“There was an error authorizing with Tidal: UnexpectedError. Please try again.”

Well I didn’t cry but I sure wasn’t happy since it’s actually gotten worse. I can’t reach Tidal from Roon at all!

I’m totaly out of ideas now.
Please help!

Post in the support area, more likely to be seen there.

1 Like