Roon Can't Find Core/ NAD M50.2 CD ripper/player settings won't load

I have a home network connected by ethernet that includes a Vortexbox ripper /server, a NAD M50.2 CD ripper & player, a sonictransporter i5 and a microrendu. The sonictransporter was my Roon core. Static IP addresses have been created for the Vortexbox ripper/server and for the NAD M50.2 ripper/server.

I am having problems getting the BluOS app on my i-phone 7 plus to load the settings for my NAD M50.2. Sometimes they load but often they don’t. What that means is that when I am ripping a CD to the NAD M50.2 I can’t see if unknown artists are being ripped. I don’t want to rip unknown artists because when I play music I can’t tell who the artist is. Kyle of BluOS has taken remote control of my computer three times to try to fix this problem to no avail.

In conjunction with this problem, after Kyle took remote control of my computer and made some adjustments I found that when I try to use the Roon app on my i-phone and on my Dell desktop computer, Roon now can’t find my Core. Do you have any solutions to these problems?


Hi @Greg_Johnson — Thanks for the report, I appreciate you reaching out!

May I kindly ask that you please describe your network configurations/topology as well as providing insight into any networking hardware you may be implementing. I would like to have a complete understanding of how your devices are communicating and what tools are being used to make those connections possible.

Additionally, can you please verify the following:

  • Since you’ve noticed this change in behavior have you attempted to reboot your Core, network devices, and remote device? Did you notice any change when doing so?
  • Have you tried reinstalling on the remote devices (not the Core)? And did you notice any changes in behavior here?
  • Are there any antivirus or firewall settings that may have been changed that could be causing this behavior?
  • Do you know what changes Kyle made on your computer? Knowing what was changed would definitely help narrow down what may have happened.


See the attached network diagram


Regarding reinstalling the BluOS app, I had enough trouble doing so initially and need BluOS’s support to do so and hopefully they can help tomorrow.

i also have trepidation about trying to reinstall the Roon app on my i-phone 7 plus as I initially had problems getting Roon to work as a core on my sonictransporter i5 which Small Green computer had to help me with. When I click on the Roon icon on my desktop computer it tries but cannot find my Roon core. You can also see the attched Roon diagnostic from for Roon on my system. I clicked on the Roon icon on my desktop computer and had it search for the cose on my system. A circle keeps revolving and it keeps looking but it cannot find the core. I am not sure what this means.

There are no antivirus or firewall settings that have changed.

Finally I don’t know what changes Kyle made except that he made the IP address for my i-phone 7 plus, a static one. Previous to that I had the IP address for the NAD M50.2 made a static one because it kept changing. For your information the changes that Kyle made to my computer initially worked to get BluOS to load Settings but after that it was back to the same old problem of settings not loading when I was ripping a CD and sometimes, but not always, loading when I was not ripping CD’s.


Hi @Greg_Johnson — Thanks for the additional information, it certainly helps!

It sounds to me that there is something causing the remote devices not to see the SonicTransporter Core machine over the network. Are you able to confirm that the SonicTransporter is connected properly?

As I mentioned above, did you give rebooting your Core, remote, and networking devices a try? Rebooting everything, particularly the network, may allow for the connection to be made to the Core.

Can you also give me a bit more detail on the switch? What model is it? Do you know if it is a managed switch?



The SonicTransporter is properly connected.

I went into and rebooted Roon but that did not change the situation.

I have rebooted the computer but how do you reboot the network?

Mark of BluOs remotely took over my computer this morning but was unable to solve the Roon problem.

I have two ethernet swtiches that are actually connected to each other. One is a Linksys SE3008 and the other one is a Linksys SE4008. That’s all I know.

Atthced is a xreenshot of the IP addresses. Also attached is a screen shot of what I get after I click on the Roon icon on my computer. When I click on “Find my Roon Core” a circle keeps revolving but nothing happens.

Can you suggest any solutions


I got Roon working again on my system this evening. On a hunch, what I did was turn off the sonicTransporter and uplug the power cord and ethernet cable from it and the microrendu. I also unplugged my Ultracap LPS-1 power supply. I then plugged them in again for power and turned them on. When I did so, Roon responded and started working. I am not sure why this did the trick because before I did that, I had checked the ethernet connections and they seemed fine and the green lights were on, on all of these units.

Thanks anyway for trying to help.