Roon can't locate library


There’s no firewall on my server and it and Roon functioned properly last night, but today I keep getting "Roon is taking longer to load & can’t locate the library – but I’ve made no changes to anything. I have rebooted the CAD CAT server 3 times as well as my iPad to no avail. That has worked in the past. I emailed for help to Roon and thus far have had no response.

This is a dedicated music server running on a modified Windows OS with everything not applicable to audio disabled- no virus software, email, etc. it is hard wired to a router extender which accesses my network. Again, nothing was altered from when my system worked last night. I wonder if Roon has made some system update which is causing this problem???

I find it very frustrating to have to ferret through miscellaneous “situations” hoping to find one close enough with SPECIFIC instructions which would be applicable to my problem(s) given that I am close to clueless with computer ‘stuff’ beyond the most rudimentary… like turning it on ; )

So thanks in advance for some help…[quote=“mike, post:5, topic:537, full:true”]
Hey guys, any chance there are firewalls involved here, on either the main installation side or the remote?

If you don’t mind, can you try turning off any firewalls running on either side, and let us know if things improve?

I’m confident we can get this working guys, but this is an important first troubleshooting step, so thanks for your patience guys.

strong text


I’d appreciate some help / answers. Last night everything worked, no changes made at my end but all I get is “Roon is searching for library” and check your remote settings. Well nothing was altered, so what’s the problem? Using a dedicated music server, CAD CAT running Windows specially modified for audio with no firewalls, email, virus, etc. It is wired to a router extender (strong one) which works with a net gear router. Has Roon made an update that could be causing the problem? I’ve received no notification. I’ve tried rebooting the CAT several times and my iPad to no avail. That worked for me before. Unfortunately I am next to clue less with this stuff. A friend set the system up for me and normally could trouble shoot remotely, but he’s now out of the country 6,000 miles away. So HELP, please with specifics. Many thanks!! Bruce

Hi Bruce,

I’ve shifted your posts to a new thread in Support so that this can get individual attention.

Can you provide details of your system as per this post ? It would also assist if you can provide such detail as you can about the network, because failing to find the library sounds like a network issue.

Build 99 was recently publicly released but Roon upgrades only occur when a user says yes to an upgrade notification. Are you able to get Roon into a state where you can see what version you are running (Settings/About) ?

Let’s drop some flags for @mike and @vova to investigate further.

Hey @Bruce_Joseph – we can absolutely get some logs and take a deeper look, but everything you’re saying sounds to me like a networking issue, particularly since there haven’t been any changes in Roon’s networking/discovery code of late.

At the risk of asking the obvious, have you restarted everything? In particular, I would restart your router, switches, and access points, in addition to anything running Roon – both your Core and any remotes as well. If you’re still having an issue here, we’ll get some logs and have a deeper look and get this working, ok @Bruce_Joseph?

@Bruce_Joseph – can you also look over the troubleshooting steps listed here? Thanks!