Roon causing conflict with SMB automounter

Core Machine (Operating system/System info/Roon build number)

MacMini/OSX 10.15.5
Roon 1.7 Build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Music Library is stored on Synology NAS connected by ethernet
NAS automounts via SMB using 3d party app “Automounter” (from Mac App Store)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I am using a third party app,, to keep my Synology NAS permanently mounted to “/Volumes” via SMB protocol. ( The idea is that if there is a disconnection for any reason, Automounter app will force the SMB share to remount - keeping the NAS permanently available for Roon.

Automounter works perfectly (ie, if the NAS disconnects or unmounts for any reason, it automatically immediately remounts to /Volumes) until Roon is started. However, once Roon starts, if the SMB share ever disappears for any reason, it will not re-mount – ie., is prevented from working. Once I reboot, Automounter works perfectly and keeps the NAS mounted (and re-mounted after disconnections) until I re-run Roon, at which point it stops working again and the NAS doesn’t remain permanently connected.

Once Roon is started, it seems to cause a conflict with how Automounter watches for SMB disconnects.

Is there some way to eliminate this conflict? Should the Automounter mount location be changed? It would be great to solve this conflict as the combination of Roon and would eliminate SMB disconnection problems and keep the NAS permanently mounted.

Hope this is clear & thanks for the assistance.

How do you specify your music folders in Roon’s Settings>Storage? What you describe can happen if you specified the music folders as an SMB mount from the NAS. I can’t recall the exact bug, it’s been several years, but basically Roon creates its own separate mount point for its SMB mount that conflicts with the other SMB mount of the same Sinology volume you have in /Volumes. Instead, you should specify the Roon music folders as /Volumes/MyMusic, where “MyMusic” stands for the mount point you asked Automounter to maintain for your NAS volume. In other words, you point Roon to the “local” macOS volume that is really the mount point for the remove NAS volume.

Hi @Jordan,

A couple of screenshots of how you have Roon Settings -> Storage configured and your Automounter settings might help, please share this when you have a chance.

Thanks both. I did as Fernando suggested, and this seems to have solved the conflict.

Automounter mounts MyNAS to /Volumes with Host as MyNAS.local
Roon Settings --> Storage is now pointed to \MyNAS.local\Music Folder

Previously I had been pointing Roon to \MyNAS\Music Folder

With Fernando’s suggestion, all seems to be working perfectly - fingers crossed!

Huge help - thanks again.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.